summaryrefslogtreecommitdiff
path: root/x11-libs/libXaw/libXaw-1.0.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-17 00:25:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-17 00:25:50 +0000
commit48dbe17904ac8ee6f006488d8f21734b0d253db4 (patch)
tree90c7f087cbefd4ac6b893072d309e75dbf019f76 /x11-libs/libXaw/libXaw-1.0.15.ebuild
parent7972abc05090180dcc09d2b16af4020ce1cd1841 (diff)
gentoo auto-resync : 17:03:2023 - 00:25:50
Diffstat (limited to 'x11-libs/libXaw/libXaw-1.0.15.ebuild')
-rw-r--r--x11-libs/libXaw/libXaw-1.0.15.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-libs/libXaw/libXaw-1.0.15.ebuild b/x11-libs/libXaw/libXaw-1.0.15.ebuild
new file mode 100644
index 000000000000..9cd7d07a7490
--- /dev/null
+++ b/x11-libs/libXaw/libXaw-1.0.15.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xaw library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="deprecated"
+
+RDEPEND="x11-base/xorg-proto
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable deprecated xaw6)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}