summaryrefslogtreecommitdiff
path: root/x11-libs/libXaw3d
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-09 23:17:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-09 23:17:55 +0000
commit8fc08491f26431ec46b36d6ebef9551f3773b96f (patch)
treed1b5bd96d856b4ddb71d02628504d39fae5c168e /x11-libs/libXaw3d
parentfd1ea0a53f74daa4fd860ac35a20ba1817fd20fa (diff)
gentoo auto-resync : 09:12:2023 - 23:17:54
Diffstat (limited to 'x11-libs/libXaw3d')
-rw-r--r--x11-libs/libXaw3d/Manifest2
-rw-r--r--x11-libs/libXaw3d/files/libXaw3d-1.6.5-c99.patch39
-rw-r--r--x11-libs/libXaw3d/libXaw3d-1.6.5-r1.ebuild37
3 files changed, 78 insertions, 0 deletions
diff --git a/x11-libs/libXaw3d/Manifest b/x11-libs/libXaw3d/Manifest
index b5ef245dd73b..37bbd9b44ff8 100644
--- a/x11-libs/libXaw3d/Manifest
+++ b/x11-libs/libXaw3d/Manifest
@@ -1,3 +1,5 @@
+AUX libXaw3d-1.6.5-c99.patch 1677 BLAKE2B fbf1666fc9e06ed7f14feec41a479f144beffc2f7f7b03c5ae8ec8ebeac387c641466efd0af6c447b800aeac4bdb3cc05025b7500a5f36fa6c9e3f879028421c SHA512 8d781999115335a2a7774bf94f4503fa7cc9e91eae5ebde5ae5305fdf968521c17a594f2d40673364c59cf038cfc14e5a13b48031e5eb767190edb5165f48488
DIST libXaw3d-1.6.5.tar.xz 483496 BLAKE2B 54dc1bb06b40685e3e2f00bc1aa8447a23ff61226c0b8d20cb0fe070bb7d914290cc4a5f2c70925da528bd9f02a283748178cb2b17111a56fbcc938a1eae25c9 SHA512 b2fbceffcbaff7c332f37769fd6b496ac820de8a80fbf9777416f1895b74a07e4efc3f2bd64db3f584983b24d2b10e9b60cf4aae3ec4a30c06510ae7c213a663
+EBUILD libXaw3d-1.6.5-r1.ebuild 806 BLAKE2B e8a06df2f84dee22961502e62cc0f56592dd76c5d416e5c5bd518daffcf97b5005335710b8291e1cdf2fdcd5acf66aebc383e6d1268a17afe2da043035b33663 SHA512 2edd76526a975d60ad0e54d0bd77cf962bcfda0a0569c419ab7ca92903623905a05b1f572916f17597d7eebcb93dd69aeb7b2f98c06413563e53c6b7243813c3
EBUILD libXaw3d-1.6.5.ebuild 749 BLAKE2B 0d99495b05914b54b69f404197369f9bf604fae482093f7e1fb87ac3a32e5acd9bba5a485f349fbb9d789657bb735440ae3d2cbb49b8cb366d1fa542ff370a8f SHA512 fedba29b66a9c24b4cac500e6c8f12237f1875a7a74fc7a8db7a9a6e4c86b1a5359904e1766f02183e0fbb161e5c10d5029d08a273d96d82511a6f8ae1440df2
MISC metadata.xml 339 BLAKE2B 60635a05848869d4aba7783f45cb02a672045a8a9b1bed933f1587ecd0ab81aa32ecc63e8a6742b4eee50a14c3e32b17b6bf14b3797e5f11e0dd74a8b582b4bf SHA512 1ed17cca85445b70786acfd900c7a75eb765001e7218e576356ef76d3e9e6399df3a45413f4650e555d2404d0c9e5f0f20f814c1bc1d08e1e8138aedbacfe50d
diff --git a/x11-libs/libXaw3d/files/libXaw3d-1.6.5-c99.patch b/x11-libs/libXaw3d/files/libXaw3d-1.6.5-c99.patch
new file mode 100644
index 000000000000..95b96f627ed3
--- /dev/null
+++ b/x11-libs/libXaw3d/files/libXaw3d-1.6.5-c99.patch
@@ -0,0 +1,39 @@
+https://bugs.gentoo.org/919373
+https://gitlab.freedesktop.org/xorg/lib/libxaw3d/-/merge_requests/10
+
+From 7b4af57e8a1471747e17fff184032d8250e598b6 Mon Sep 17 00:00:00 2001
+From: Alan Coopersmith <alan.coopersmith@oracle.com>
+Date: Thu, 7 Dec 2023 18:01:47 -0800
+Subject: [PATCH] Multisink.c: Clear -Werror=incompatible-pointer-types error
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+MultiSink.c: In function ‘SetValues’:
+MultiSink.c:582:18: error: passing argument 1 of ‘SetTabs’ from
+ incompatible pointer type [-Werror=incompatible-pointer-types]
+ 582 | SetTabs( w, w->text_sink.tab_count, w->text_sink.char_tabs );
+ | ^
+ | |
+ | MultiSinkObject {aka struct _MultiSinkRec *}
+MultiSink.c:99:21: note: expected ‘Widget’ {aka ‘struct _WidgetRec *’}
+ but argument is of type ‘MultiSinkObject’ {aka ‘struct _MultiSinkRec *’}
+ 99 | static void SetTabs(Widget, int, short *);
+ | ^~~~~~
+
+Adopts change originally made to libXaw in XFree86 4
+
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+--- a/src/MultiSink.c
++++ b/src/MultiSink.c
+@@ -579,7 +579,7 @@ SetValues(Widget current, Widget request, Widget new, ArgList args, Cardinal *nu
+ if ( w->multi_sink.fontset != old_w->multi_sink.fontset ) {
+ ((TextWidget)XtParent(new))->text.redisplay_needed = True;
+ #ifndef NO_TAB_FIX
+- SetTabs( w, w->text_sink.tab_count, w->text_sink.char_tabs );
++ SetTabs((Widget)w, w->text_sink.tab_count, w->text_sink.char_tabs);
+ #endif
+ }
+
+--
+GitLab
diff --git a/x11-libs/libXaw3d/libXaw3d-1.6.5-r1.ebuild b/x11-libs/libXaw3d/libXaw3d-1.6.5-r1.ebuild
new file mode 100644
index 000000000000..180315f6ad32
--- /dev/null
+++ b/x11-libs/libXaw3d/libXaw3d-1.6.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xaw3d library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="xpm"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt
+ xpm? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ sys-devel/flex
+ app-alternatives/yacc"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.5-c99.patch
+)
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-internationalization
+ $(use_enable xpm multiplane-bitmaps)
+ --enable-gray-stipples
+ --enable-arrow-scrollbars
+ )
+ xorg-3_src_configure
+}