summaryrefslogtreecommitdiff
path: root/x11-libs/libxcb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-17 03:31:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-17 03:31:10 +0100
commit280d9db9f9470686aae5ce1fa4cfa57b26e9beb2 (patch)
tree604fa555cdb815d5774494412f041887debf5220 /x11-libs/libxcb
parent2ef316f0ffbd90d833effd2d09d1232e5767e321 (diff)
gentoo auto-resync : 17:08:2023 - 03:31:10
Diffstat (limited to 'x11-libs/libxcb')
-rw-r--r--x11-libs/libxcb/Manifest2
-rw-r--r--x11-libs/libxcb/libxcb-1.16.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-libs/libxcb/Manifest b/x11-libs/libxcb/Manifest
index 228db47ba073..8135b5b846e5 100644
--- a/x11-libs/libxcb/Manifest
+++ b/x11-libs/libxcb/Manifest
@@ -1,3 +1,5 @@
DIST libxcb-1.15.tar.xz 446492 BLAKE2B d50146ee9b822dfd0c24513110e1706cda05ce588f276005167a911d3097275f36be1ce755c42c2b2970e750f10b2b943f3e373b6e55865fba986e29811a3545 SHA512 f6c7d766b7cf9cab6abe948ee424cbae6951dbfe2f76fa58a109cdc05b0f0919dcc4e38176a22ff4b95fc1e38596115317e32ba33b24cae0035a4e30dbcbdad9
+DIST libxcb-1.16.tar.xz 452964 BLAKE2B 1ddd5c2e6be8400a0a77db4b5fbd4698996fd1a00984e370b1f712f6b9ce456c8ccfb6992f2973f5eaf8d5b6b75f39b9f51a1458c2432ddb41edd8199b91b3f9 SHA512 002fbc126c6f09eb7db5e4197cd0572d495f64b6de714a76d9a024fe3e13122c1cfc7c55207c0dee76cc63fcccf87b37db513223eadaf760af2bd2a926443bf8
EBUILD libxcb-1.15-r1.ebuild 1374 BLAKE2B 965d267226e8aec57c83f900f0aee8f47037e2861731047e08b3cbbefd7bafe63ea8b29b1e98675060f01fa3706a7f117a45b3e248d56f97b5cd03cf0e19fd00 SHA512 a806211fdc8c7b9ff9b444d55638e344a7731a3f9ea8d888d6d818c2cd20d9acc2dd476ee469bb32ce28e7d7ea4f29bd05191e3db561c52233c5392057cf5c3a
+EBUILD libxcb-1.16.ebuild 1383 BLAKE2B 8d0a046beb5c302703be4138c2cc13c011a02158d6e5b7ddbd17b2db846d55ed568dac2ce6163f18c47138a7c6697235bb149388c6d921578d25c782995511fe SHA512 cc0b0353a509e01f03f4b71c7cbddd7c12db0e84e77fa536ed1956d90f325b64f49414d52946b9104a771a245a028954aa61c7b69715473b384b9992ace51d44
MISC metadata.xml 470 BLAKE2B 9f530dabef12ece5a3ccaade8000872e1a89cfef4833ca4d6a4c5e157510516fec18f18e7dbe4ae88ac4059acff9fd099832c3614d12d9742af03167def25f16 SHA512 884ca6cde9de9394a67493b5ec40475873e363ad2530470ebbc0e080f55594bf02787b02960ad172ba05e736c80a6b9c33aa9c2ceaf1b47005f6f47b0895c1a3
diff --git a/x11-libs/libxcb/libxcb-1.16.ebuild b/x11-libs/libxcb/libxcb-1.16.ebuild
new file mode 100644
index 000000000000..398a90536147
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.16.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+XORG_TARBALL_SUFFIX="xz"
+XORG_MULTILIB=yes
+XORG_DOC=doc
+
+inherit python-any-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc selinux test +xkb"
+RESTRICT="!test? ( test )"
+SLOT="0/1.12"
+
+RDEPEND="
+ >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXdmcp-1.1.1-r1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ >=x11-base/xcb-proto-1.15.2
+ elibc_Darwin? ( dev-libs/libpthread-stubs )
+ test? ( dev-libs/check[${MULTILIB_USEDEP}] )
+"
+# Note: ${PYTHON_USEDEP} needs to go verbatim
+BDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep '>=x11-base/xcb-proto-1.15[${PYTHON_USEDEP}]')
+ doc? ( app-doc/doxygen[dot] )
+ test? ( dev-libs/libxslt )
+"
+
+python_check_deps() {
+ python_has_version ">=x11-base/xcb-proto-1.15[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ xorg-3_pkg_setup
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc devel-docs)
+ $(use_enable selinux)
+ )
+ xorg-3_src_configure
+}