summaryrefslogtreecommitdiff
path: root/x11-libs/vte/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /x11-libs/vte/files
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'x11-libs/vte/files')
-rw-r--r--x11-libs/vte/files/vte-0.64.1-meson-Find-python-explicitly-to-honor-downstream-pyt.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-libs/vte/files/vte-0.64.1-meson-Find-python-explicitly-to-honor-downstream-pyt.patch b/x11-libs/vte/files/vte-0.64.1-meson-Find-python-explicitly-to-honor-downstream-pyt.patch
new file mode 100644
index 000000000000..79171d29dead
--- /dev/null
+++ b/x11-libs/vte/files/vte-0.64.1-meson-Find-python-explicitly-to-honor-downstream-pyt.patch
@@ -0,0 +1,48 @@
+https://gitlab.gnome.org/GNOME/vte/-/issues/350
+
+From d459d32126119c8d78f8239b8b857a255e6005d7 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Sat, 1 May 2021 08:31:45 -0400
+Subject: [PATCH] meson: Find python explicitly to honor downstream python
+ choice
+
+---
+ meson.build | 1 +
+ src/meson.build | 2 ++
+ 2 files changed, 3 insertions(+)
+
+diff --git a/meson.build b/meson.build
+index 4f5a7c57..6404802f 100644
+--- a/meson.build
++++ b/meson.build
+@@ -461,6 +461,7 @@ pango_dep = dependency('pango', version: '>=' + pango_req_version)
+ pcre2_dep = dependency('libpcre2-8', version: '>=' + pcre2_req_version)
+ pthreads_dep = dependency('threads')
+ zlib_dep = dependency('zlib')
++python = import('python').find_installation('python3')
+
+ if get_option('fribidi')
+ fribidi_dep = dependency('fribidi', version: '>=' + fribidi_req_version)
+diff --git a/src/meson.build b/src/meson.build
+index a1440da5..4ac6a7f2 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -60,6 +60,7 @@ modes_sources = files(
+ modes_sources += custom_target(
+ 'modes',
+ command: [
++ python,
+ files('modes.py'),
+ '--destdir', '@OUTDIR@',
+ ],
+@@ -92,6 +93,7 @@ parser_sources = files(
+ parser_sources += custom_target(
+ 'parser-seq',
+ command: [
++ python,
+ files('parser-seq.py'),
+ '--destdir', '@OUTDIR@',
+ ],
+--
+2.26.3
+