summaryrefslogtreecommitdiff
path: root/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r3.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r3.ebuild')
-rw-r--r--x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r3.ebuild b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r3.ebuild
new file mode 100644
index 000000000000..c992d55d7ccc
--- /dev/null
+++ b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb-cursor"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-image-0.3.9-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-renderutil-0.3.9[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=x11-base/xcb-proto-1.8-r3:=[${MULTILIB_USEDEP}]
+ x11-base/xorg-proto"
+BDEPEND=">=dev-util/gperf-3.0.1"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-cursorpath='~/.cursors:~/.icons:/usr/local/share/cursors/xorg-x11:/usr/local/share/cursors:/usr/local/share/icons:/usr/local/share/pixmaps:/usr/share/cursors/xorg-x11:/usr/share/cursors:/usr/share/pixmaps/xorg-x11:/usr/share/icons:/usr/share/pixmaps'
+)