summaryrefslogtreecommitdiff
path: root/x11-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-07 03:03:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-07 03:03:27 +0000
commitabe17cf152eeb7571da8db4b25a30465644a41ba (patch)
tree33e648f624199affa607b84e65868f73d25281e6 /x11-libs
parent2ceda67569b0a59d190a0f6afe73c18336b54268 (diff)
gentoo auto-resync : 07:11:2024 - 03:03:27
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/Manifest.gzbin17865 -> 17861 bytes
-rw-r--r--x11-libs/libXcursor/Manifest2
-rw-r--r--x11-libs/libXcursor/libXcursor-1.2.3.ebuild24
3 files changed, 26 insertions, 0 deletions
diff --git a/x11-libs/Manifest.gz b/x11-libs/Manifest.gz
index 0bd9f3aebcee..01bb59a59849 100644
--- a/x11-libs/Manifest.gz
+++ b/x11-libs/Manifest.gz
Binary files differ
diff --git a/x11-libs/libXcursor/Manifest b/x11-libs/libXcursor/Manifest
index bd1f3b63144a..197280419475 100644
--- a/x11-libs/libXcursor/Manifest
+++ b/x11-libs/libXcursor/Manifest
@@ -1,3 +1,5 @@
DIST libXcursor-1.2.2.tar.xz 289536 BLAKE2B 1619f71a514586bab7651aa47702a06a3b6e8d9c60b27c7eabe39b49dff9e83a050b88e171fdde4735ad4c62b1be4be10c84af35bb3e78dedccd9cd85fe3680c SHA512 6550ce1e69b35ef3356f25e31aa2779503d9cea780eff307cb646364993dfaa971304085d32677e68996bd3b8e067436c8fc89aeb4db07a12ce5bc93b735b5b0
+DIST libXcursor-1.2.3.tar.xz 292764 BLAKE2B 46e95522d2ff45e5d2b3bfe4570de54ab9189e05956831996dee688cb306962ae5b5b37bfa49bffc8e9d0cf23b6ee501f65b24094b815c46f50baf2de7ea42ef SHA512 069a1eb27a0ee1b29b251bb6c2d0688543a791d6862fad643279e86736e1c12ca6fc02b85b8611c225a9735dc00efab84672d42b547baa97304362f0c5ae0b5a
EBUILD libXcursor-1.2.2.ebuild 904 BLAKE2B 86286399d7f7df16986e3436c5c6d5fbeb3e1e9f9b655a6ac4ae9d864330f5c0e5a4f917f723a2b81058b0424bdb2092211fbb3cbe2a977d72ef344e2731f1d9 SHA512 214606002149bb5c69c08c3cec723edbd59df1b81c8d7f57b907ea532c659a821c1e121353851da795a300dc809f4ff16fc34e5ba772ed8a53db729238f862e6
+EBUILD libXcursor-1.2.3.ebuild 912 BLAKE2B 43c8020b3657f4af9a7431b124e5d60c36a8271c6909d0f84099a9581a75592d8198eebec9403d1b0de9d8b071c73d5c8c81793450b5ff6844f9657303951a23 SHA512 30afe60f83e0b4f85b95b4bfc2093760f47d80d458e9f1ac3a260ba78579721969f0617bda5957c4bc1acb14ad7c711e79bef3e641a205ce0d073dd17daac29d
MISC metadata.xml 341 BLAKE2B c8efd915b38a2d39c542bcbab6fc55b5d6e9859e3c81064f666bacc342f3eee63c2cc1e4f9e6ce095d28242c2e7d04021eb0c34b3088da601fa9c8c78ad28bff SHA512 e11bbb32b278b773e6a393a574c80ab35b84e8eddb542a85df8c288005476de58c326605de76ba7a37504100a20a71ef1bbd61f3402af3f79a81a28d60ac4d90
diff --git a/x11-libs/libXcursor/libXcursor-1.2.3.ebuild b/x11-libs/libXcursor/libXcursor-1.2.3.ebuild
new file mode 100644
index 000000000000..b72ade14debf
--- /dev/null
+++ b/x11-libs/libXcursor/libXcursor-1.2.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+DESCRIPTION="X.Org Xcursor library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-icondir="${EPREFIX}"/usr/share/cursors/xorg-x11
+ --with-cursorpath='~/.cursors:~/.icons:/usr/local/share/cursors/xorg-x11:/usr/local/share/cursors:/usr/local/share/icons:/usr/local/share/pixmaps:/usr/share/cursors/xorg-x11:/usr/share/cursors:/usr/share/pixmaps/xorg-x11:/usr/share/icons:/usr/share/pixmaps'
+)