summaryrefslogtreecommitdiff
path: root/x11-misc/albert
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-10 19:15:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-10 19:15:28 +0000
commitda6a52f691ef980bab92d003d5df8f463c623af8 (patch)
tree4d89e0d5915f8a3f57c8f9c17420ba3f7b44b7b2 /x11-misc/albert
parent80208fb578cf92cc308906660ca6d7860c6b2a1f (diff)
gentoo resync : 10.03.2018
Diffstat (limited to 'x11-misc/albert')
-rw-r--r--x11-misc/albert/Manifest3
-rw-r--r--x11-misc/albert/albert-0.14.16.ebuild58
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/albert/Manifest b/x11-misc/albert/Manifest
index 266bff4b03e5..c30176678616 100644
--- a/x11-misc/albert/Manifest
+++ b/x11-misc/albert/Manifest
@@ -1,4 +1,7 @@
DIST albert-0.14.15-plugins.tar.gz 540189 BLAKE2B b8243917cdd30c74f26ad852421cf525047694aaae2ec170a31d6239f7fa704de72f9ef67564282136ca15ec1960a1c882c193a2339541e0bf40986ee10588cb SHA512 1af59c65bd91ac626abd8777b350c92a4532a88119bd9ec6ff55f9f3ad72e5cfd6987c9b34f1c32ca854891e91f79ffbea04ed23fa85a18826e9aa890b400079
DIST albert-0.14.15.tar.gz 84875 BLAKE2B 80e173100a0d135a18b20482ef0eb103634207b1e1a7284b2c5245750bc22478026b25982b714b3fcd079ed7674075a6853917d789f99628a368c6a9c6fd344d SHA512 9a6efd9203f7b96aa14c063a9de8c59e6b4bb0a5c55a64662ec170b75fc71247b7313a1252f71ab2516b4b62538f4c89778a43b8804915996636f49d4e0a6d31
+DIST albert-0.14.16-plugins.tar.gz 540297 BLAKE2B e859ff84332fe32ca0513700dd3ee099ef99f240823c70387f630877f972fccf86baab477d0ec5fe166bb979fb6509e9a3ef5e9bb04ba365e789da74d3508555 SHA512 06cefb99ec2da0ccd4ad1f4729cb5626611ba3b226ccae9c8448ad2c58e61790dfd391dcd963524762587b82739f2267aea6b2a2b7affa4c946d6ba438678383
+DIST albert-0.14.16.tar.gz 84708 BLAKE2B e901518cf36fd3a68e6b5ddd4f0937ed0cff62f9a8e541b8319670893e2a38c47d222c6e3f25a9673bd1e11ad357382a3441e55497609d049f2b287c97ce6484 SHA512 92708909ed8a91ac2c16ba967c8506a15d4cc74cbb88111761ab18941c3bbab040f5b379b8c780887024b53710b05ad1ce80ffe41bd252358daf80c19b2c953b
EBUILD albert-0.14.15.ebuild 1346 BLAKE2B 7a1916d46b46373c184fb7dde8748d247eefb4d95e2d04127597c97c1fe4eda6be3bb03bc9eb938aceaf3e3e01c5de4f2c357781e2a359cdb3c27371530a54ce SHA512 a6ff9c7d06c9182f9fc62de3489c8fc0b3a5172432faa0512c0e1142d004e53c58fa22adb03730e7878c029fc3eb83ac603c94feeb85e8080243b33368f6858c
+EBUILD albert-0.14.16.ebuild 1347 BLAKE2B 07b1ddacfe18837b4a0a71281d0c8cc88b88536a3014d2e6f218e0f609fd2e88598a81c017aa1d5478d7070d030ec375a04629e72834224a2e886c93a9a7715d SHA512 d37c18a94e1790d5882f7545e7b09c0afe86ac536dc1cb950cfb2f378da6944bcabad541a8eff503b88ed3d280ad6fbd82298bcbe3d89782c968da29c71b4df8
MISC metadata.xml 307 BLAKE2B 8113fd9d5c144840eca96ffa19f81d1406343eb5fd60030739bce0a1fe3b469dfbda7066137a3347a4743abbfbbbb08a61712ca2fd681dd6f60e8d7f166336c7 SHA512 2e041e46839e742b36835304388ab2504f46a1a0f9fde76bca26e06e5db570a55e929310a7a06661ee115f5957c089a39125c5c41e42927263551e07d1c5b31a
diff --git a/x11-misc/albert/albert-0.14.16.ebuild b/x11-misc/albert/albert-0.14.16.ebuild
new file mode 100644
index 000000000000..3c586fcd9f58
--- /dev/null
+++ b/x11-misc/albert/albert-0.14.16.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLUGINS_HASH="c92234731b5dae3baca6eb4e0561cd7ee90e7b56"
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Desktop agnostic launcher"
+HOMEPAGE="https://albertlauncher.github.io/"
+# plugins is a git submodule. the hash is taken from the submodule reference in the ${PV} tag.
+SRC_URI="https://github.com/albertlauncher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/albertlauncher/plugins/archive/${PLUGINS_HASH}.tar.gz -> ${P}-plugins.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND="
+ dev-cpp/muParser
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ mv "${WORKDIR}"/plugins-${PLUGINS_HASH}/* "${S}"/plugins/ || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DEBUG=$(usex debug)
+ -DBUILD_PYTHON=OFF #plugin directory is empty causing build failure
+ -DBUILD_VIRTUALBOX=OFF #plugin needs virtualbox installed to build, untested
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}