summaryrefslogtreecommitdiff
path: root/x11-misc/arandr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
commit7a86906b67693cc65671d3e1476835d3a7e13092 (patch)
tree9de1b9e2cf77833183d4e5ffab2e94d0403ef725 /x11-misc/arandr
parentd56d144655e3785864da43c9acb6c228ef9360ae (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'x11-misc/arandr')
-rw-r--r--x11-misc/arandr/arandr-0.1.10.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/arandr/arandr-0.1.10.ebuild b/x11-misc/arandr/arandr-0.1.10.ebuild
new file mode 100644
index 000000000000..6025bf9d41d0
--- /dev/null
+++ b/x11-misc/arandr/arandr-0.1.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Another XRandR GUI"
+HOMEPAGE="https://christian.amsuess.com/tools/arandr/"
+SRC_URI="${HOMEPAGE}/files/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pygobject:3=[${PYTHON_USEDEP}]
+ x11-apps/xrandr
+"
+DEPEND="
+ >=dev-python/docutils-0.6[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ local i p
+ # simulate gettext behavior:
+ # LINGUAS unset => install all
+ # LINGUAS="" => install none
+ # LINGUAS="de fr" => install de and fr
+ if [[ -n "${LINGUAS+x}" ]] ; then # if LINGUAS is set
+ for i in $(cd "${S}"/data/po ; for p in *.po ; do echo ${p%.po} ; done) ; do # for every supported language
+ if ! has ${i} ${LINGUAS} ; then # if language is disabled
+ rm data/po/${i}.po || die
+ fi
+ done
+ fi
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ gunzip "${D}"/usr/share/man/man1/{${PN},unxrandr}.1.gz || die
+}