summaryrefslogtreecommitdiff
path: root/x11-misc/bbrun/bbrun-1.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-misc/bbrun/bbrun-1.6-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-misc/bbrun/bbrun-1.6-r1.ebuild')
-rw-r--r--x11-misc/bbrun/bbrun-1.6-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/x11-misc/bbrun/bbrun-1.6-r1.ebuild b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
index 0ae88b552435..a6a1b752e378 100644
--- a/x11-misc/bbrun/bbrun-1.6-r1.ebuild
+++ b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,7 +29,14 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc-10.patch
)
+src_prepare() {
+ default
+ sed -i -e "/LIBDIR =/s:lib:$(get_libdir):" bbrun/Makefile || die
+}
+
src_compile() {
+ tc-export PKG_CONFIG
+
emake -C ${PN} CC="$(tc-getCC)"
}