summaryrefslogtreecommitdiff
path: root/x11-misc/calise
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/calise
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/calise')
-rw-r--r--x11-misc/calise/Manifest5
-rw-r--r--x11-misc/calise/calise-0.4.2.ebuild57
-rw-r--r--x11-misc/calise/metadata.xml15
3 files changed, 77 insertions, 0 deletions
diff --git a/x11-misc/calise/Manifest b/x11-misc/calise/Manifest
new file mode 100644
index 000000000000..63787f0862e8
--- /dev/null
+++ b/x11-misc/calise/Manifest
@@ -0,0 +1,5 @@
+DIST calise-0.4.2.tar.gz 102792 SHA256 fdc380fea57a10a22e3fc3a61f57ee988b56e144db29ac1ce79e76d4e2971551 SHA512 b08722083447780dbfe6a3614cf0891eed791819adc6c434b878c55cbad6fa122d3c2042274fe9acbc0c68a2acb3ca7835422ec6d2d1f867d6fd9ec806a4f750 WHIRLPOOL 6399b583c024ec8c0a507de941d5d3ce4dff895f261bf127f7bc8583e2a15af1d8db965b04458beb11c5c829dad917973c49a8f4f3fc2da2497fcd9a88879398
+EBUILD calise-0.4.2.ebuild 1506 SHA256 e92a50ae2239c0c582f51f705c71b0a70feecd75596149311fa2342491f4680c SHA512 3e4a437d98ca82d716864a085d678c433235867401f17648d5a8a3b437d19c367bd5b90521ec84d2f09e9819e5f754dc04a5ae7a468eff800e87bf036ff402c3 WHIRLPOOL 00dbbd26f1a898ea22e262c969750c64e4aae22716574f75d1d9245372782e268726cf1af2335e244916fee2bbc6db9ec907c456fb79b2bc666ba07c650029f1
+MISC ChangeLog 3081 SHA256 5699a93dec526bbf75732c0d65830b467c03a02aa34106442eff5f4fc681763c SHA512 9f8e1e0fb613fd31e9ab198a47d3b098c7b75f6a161218108fa518fa3de2c891f53a0d26cc6516ec8d3242d35a4a690da680cb1735c4b30ee4cd4413da8a8a88 WHIRLPOOL 035be15ad2b2206e8fab3bdb430a8948db979201f849b5afea5a3d1d5222d23f8e6e7d4e4a683ffc3f357bf9fa331d1d4775aebfb4abf2af1683f9f175a05eb8
+MISC ChangeLog-2015 831 SHA256 ac5ee522dc54f2ff7e890a65eff723ccc861f6e0a982155a769b8f8b25db16f0 SHA512 3f75637b78e261bf9a85a5ea7b65d739346440cc74b1f1868e6bc2816c248b50fc89e65baa84b7e001c22387ae8d8322424cccb840a76b403de3fc99718c64aa WHIRLPOOL a984e1b5ff131e4facd3664955edf8d52bb67bb7cf54501c6ceffea59f75935599623cbc1da247b6f4396e0807649d46f7d4773806d1d5125eace07ab3d2be2a
+MISC metadata.xml 434 SHA256 0ecd7f7666d59e0719337ad5834ed2fd7fdb4d2a13f74da494b65168feaab97e SHA512 f2e544211ea0fa26be86ec4faa6124b10a5af4a348a06122a99a783a74e1d9b37c0ccd6e6e26689474f752e3dd98095d13fdfa5df4ae669e3adec7b8a5713c7c WHIRLPOOL 5c1ba83b3d99b8cb0a02d0b4d772bcca9e8d9794f000d84d4e7076ac6c90820ac435dc5917ca07c3be1348fab6aae84cf149084fa3799579f36b3e2cbb4cc2e4
diff --git a/x11-misc/calise/calise-0.4.2.ebuild b/x11-misc/calise/calise-0.4.2.ebuild
new file mode 100644
index 000000000000..e09f3e679903
--- /dev/null
+++ b/x11-misc/calise/calise-0.4.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1 linux-info systemd
+
+DESCRIPTION="Computes ambient brightness and sets screen's correct backlight using a webcam"
+HOMEPAGE="http://calise.sourceforge.net/"
+SRC_URI="https://sourceforge.net/projects/${PN}/files/${PN}-beta/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CDEPEND="${RDEPEND}
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ sci-astronomy/pyephem[${PYTHON_USEDEP}]
+ x11-themes/hicolor-icon-theme"
+DEPEND="${CDEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ dev-util/intltool
+ sys-kernel/linux-headers
+ x11-libs/libX11"
+RDEPEND="${CDEPEND}"
+
+CONFIG_CHECK="~BACKLIGHT_CLASS_DEVICE"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # Add missing trailing ; to desktop file.
+ sed -i 's/^\(Categories=Utility\)$/\1;/' \
+ share/applications/calise.desktop.in || die
+
+ # Fix up bashisms.
+ sed -i 's:&>/dev/null:2>\&1 >/dev/null:' \
+ other/init_scripts/init.d/${PN}d || die
+}
+
+src_install() {
+ doconfd other/init_scripts/conf.d/${PN}d
+ doinitd other/init_scripts/init.d/${PN}d
+ systemd_dounit other/systemd_scripts/${PN}d.service
+
+ install -D -m755 other/pm-utils_scripts/53${PN}d "${D}"/usr/lib/pm-utils/sleep.d/53${PN}d
+
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ einfo "Optional runtime dependency: dev-python/PyQt4 for GUI"
+}
diff --git a/x11-misc/calise/metadata.xml b/x11-misc/calise/metadata.xml
new file mode 100644
index 000000000000..4e24c1984732
--- /dev/null
+++ b/x11-misc/calise/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alex_y_xu@yahoo.ca</email>
+ <name>Alex Xu</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">calise</remote-id>
+ </upstream>
+</pkgmetadata>