summaryrefslogtreecommitdiff
path: root/x11-misc/devilspie/devilspie-0.23.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/devilspie/devilspie-0.23.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/devilspie/devilspie-0.23.ebuild')
-rw-r--r--x11-misc/devilspie/devilspie-0.23.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/devilspie/devilspie-0.23.ebuild b/x11-misc/devilspie/devilspie-0.23.ebuild
new file mode 100644
index 000000000000..ef185b8f810e
--- /dev/null
+++ b/x11-misc/devilspie/devilspie-0.23.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A Window Matching utility similar to Sawfish's Matched Windows feature"
+HOMEPAGE="http://www.burtonini.com/blog/tag/devilspie.html"
+SRC_URI="http://www.burtonini.com/computing/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.10
+ x11-libs/gtk+:3[X]
+ x11-libs/libwnck:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ gnome-base/gnome-common" # Required by eautoreconf
+
+src_prepare() {
+ default
+ sed -i -e "s:\(/usr/share/doc/devilspie\):\1-${PVR}:" devilspie.1 || die
+ sed -i -e '/-DG.*_DISABLE_DEPRECATED/d' src/Makefile.am || die
+ mv configure.{in,ac} || die
+ eautoreconf
+ LIBS="$($(tc-getPKG_CONFIG) --libs x11)"
+}
+
+src_install() {
+ default
+ keepdir /etc/devilspie
+}