summaryrefslogtreecommitdiff
path: root/x11-misc/dsx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/dsx
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/dsx')
-rw-r--r--x11-misc/dsx/Manifest5
-rw-r--r--x11-misc/dsx/dsx-0.1-r1.ebuild29
-rw-r--r--x11-misc/dsx/files/dsx-0.172
-rw-r--r--x11-misc/dsx/metadata.xml8
4 files changed, 114 insertions, 0 deletions
diff --git a/x11-misc/dsx/Manifest b/x11-misc/dsx/Manifest
new file mode 100644
index 000000000000..092105f374fb
--- /dev/null
+++ b/x11-misc/dsx/Manifest
@@ -0,0 +1,5 @@
+AUX dsx-0.1 2218 SHA256 4d1835e19ed1f10edbe56e1d39e06ba51f6653f9ca9f3e680b61766f31ba05bb SHA512 918d05297dc39166fe1684b306441c519bdf41e56a94d4a5f090698f69fdebb1f4d077d07be4e6d5a22614f163eb4ff8645c8751397ba52e265daece840178a9 WHIRLPOOL b026fad6027ed19b725775855e0d9ef4575ddb9e329dc2a8988e03932e20c0e103817ebdbdfaaa1ac844c2b474151b60123cf33401cd767af84e5d3ba04cac1d
+EBUILD dsx-0.1-r1.ebuild 516 SHA256 783d89927639ee2627516b10b0bb195777261f9219907827207c3733ca0b92c3 SHA512 212fc9f5f553792a7dfb24b0d879178b74a20ca636f073e92b45117b559f23ec23b5e7d99cb5af0b0dd3ca810658f2f362b2c339d9d8378bee2a00d0e987e545 WHIRLPOOL c81ffef63207fb9da6e4844d14c84dddb0ce5ca7759a97190db86243d7ec6b7e8cd990bdbfd114486fdb20de001ca945df21ce0516c6a917191f90a137a95128
+MISC ChangeLog 2443 SHA256 9d384e250b23cb4f05f93cfe86147bbde64acb3a44932af26cf59b437823fc90 SHA512 ec907902d1f3499cb774e098f03000c94f2a37896a0bda362b34ae740fe7eff83b9c0e47067983bb1de30771095d27c820040a5fcf99707191aac6cf7cd59865 WHIRLPOOL c797f71b5d5748634e0a4bf9dcb4dfd4e935c9d9d70b7774f6daf8705d3b45657f66b4211a1c34de2b755f9e0dc5bd2a4a528e46f831a2f6325512b3d779ff8f
+MISC ChangeLog-2015 1049 SHA256 69be9327783bae36dce2ebe86be4d423e93a8650b3f7c136a573aa59bbdf195b SHA512 a0cf00f2ddc90ea56ec3c91e65d82f95b4739b169e7df3e16a36095b1f29351c310db370169fb2313f58048a9b0eb0c3df8434f9b3d06b9479dabbabffc2c552 WHIRLPOOL b7c9549da1abf7dc91b048aae860b4c3933233b719b1d542273174949cf5bdae5e1951466ae933b6a8b7f1c49ca1c6720a48ff09def0a33aea75869e08a62749
+MISC metadata.xml 272 SHA256 b389ad9ba70c18154af4fc164e31d5b1e2a4e99815d34319b4a4f46ccef2be52 SHA512 ebe67da08587903b5b82fc194aa3c8f1ab65371f60d2c134928362e089550d9e9fd9531bffe8b676a345b5bf0ab209ce7f50d37d98201a88176f002e17582493 WHIRLPOOL 3d6a9660a11c299dbb7fa3ec6821005f2540dc8fc9e499206d38d79d54023b3ddc66a019b2c88fbc92199b9f5335088b47fa3fdd781f92f2da3ad98b26bc2a50
diff --git a/x11-misc/dsx/dsx-0.1-r1.ebuild b/x11-misc/dsx/dsx-0.1-r1.ebuild
new file mode 100644
index 000000000000..fe4368e5c75d
--- /dev/null
+++ b/x11-misc/dsx/dsx-0.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Command line selection of your X desktop environment"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+ x11-apps/xinit"
+
+S="${WORKDIR}"
+
+src_install() {
+ python_newscript "${FILESDIR}/${P}" "${PN}"
+}
diff --git a/x11-misc/dsx/files/dsx-0.1 b/x11-misc/dsx/files/dsx-0.1
new file mode 100644
index 000000000000..d8f5e7192928
--- /dev/null
+++ b/x11-misc/dsx/files/dsx-0.1
@@ -0,0 +1,72 @@
+#!/usr/bin/env python
+# dsx is Mandrakesoft's Xtart modified to work with a Gentoo Linux system.
+# Gentoo doesn't use a wmsession.d directory, so we're going to accept the
+# /etc/X11/Sessions executables as our menu and our command parameters.
+# I also tried to increase the robustness of the entry checking and make the
+# error messages less condescending.
+# The 0 option for "no wm" was removed. I altered it to run option 1 instead.
+
+### Original copyright / license message from Xtart... ###
+# This is an official linux-mandrake extension of the X windowing system for
+# the benefit of Declan Moriarty Copyright 2001 by civileme@mandrakesoft all
+# rights reserved. Use is hereby granted under the GNU General Publoic
+# License version 2 or any future version of said license at the user's option
+#
+# No Warranty of course.
+# This program is designed for those who want to work in concole and
+# occasionally boot into window managers or who want to avoid theme
+# persistence from one WM to another.
+################
+import sys
+import os
+import popen2
+import string
+import math
+def complain():
+ print 'X initiation aborted on invalid selection.'
+ sys.exit(0)
+ return
+print
+print 'Welcome to the Desktop Selector for X'
+print
+fspc=os.path.expanduser('~')+'/'
+io=popen2.Popen3('ls /etc/X11/Sessions',1)
+L=io.fromchild.readlines()
+Sessions={}
+Sessionkeys=[]
+primekey=0
+for k in L:
+ primekey+=1
+ name=k[:-1]
+ command='/etc/X11/Sessions/'+k[:-1]
+ Sessions[primekey]=(name, command)
+Sessionkeys=Sessions.keys()
+Sessionkeys.sort()
+for j in Sessionkeys:
+ if os.system('[ -x '+Sessions[j][1]+' ]') == 0:
+ print j, Sessions[j][0]
+ pass
+print
+sys.stdin.flush()
+s=raw_input('Enter the number of your desired desktop environment [1]: ')
+if len(s)==0:
+ s='1'
+if s=='0':
+ s='1'
+for j in range(len(s)):
+ if string.find(string.digits,s[j]) == -1:
+ print "'" + s[j] + "' isn't a digit."
+ complain()
+if len(s)>int(math.log10(primekey))+1:
+ print "That number is too big."
+ complain()
+well=int(s)
+wellformed=Sessions.has_key(well)
+if wellformed:
+ os.execvp('xinit',Sessions[well])
+else:
+ print
+ print 'Your selection was invalid.'
+ print
+ complain()
+
diff --git a/x11-misc/dsx/metadata.xml b/x11-misc/dsx/metadata.xml
new file mode 100644
index 000000000000..49c86a887b6a
--- /dev/null
+++ b/x11-misc/dsx/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>desktop-misc@gentoo.org</email>
+ <name>Gentoo Desktop Miscellaneous Project</name>
+</maintainer>
+</pkgmetadata>