summaryrefslogtreecommitdiff
path: root/x11-misc/gigolo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-27 06:30:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-27 06:30:35 +0000
commit721e451ec418e1712f6962404e111f0ebd487389 (patch)
treeaab5b35236af464349c2522312c63b664273465c /x11-misc/gigolo
parente80134587e8d959a88dba7dd3784895372e205c8 (diff)
gentoo auto-resync : 27:12:2024 - 06:30:34
Diffstat (limited to 'x11-misc/gigolo')
-rw-r--r--x11-misc/gigolo/Manifest2
-rw-r--r--x11-misc/gigolo/gigolo-0.5.4.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/gigolo/Manifest b/x11-misc/gigolo/Manifest
index 723734140c63..3824703c6376 100644
--- a/x11-misc/gigolo/Manifest
+++ b/x11-misc/gigolo/Manifest
@@ -1,3 +1,5 @@
DIST gigolo-0.5.3.tar.bz2 304664 BLAKE2B 958e2cdbd043adf1e4f166ca6435462ee2621d7f7bc4918505715bc3240f5ee2a60fb5a27f23a607a1ffd862d41123dfd5977aa87f7c4fe1c7a085d05aac3b2a SHA512 46d93d4c2654a91724208f144098f0a870465823a516339c8455345b5d32be6efe2b7fb13d3e5c89daf2cd919e07e5fcbdc8c8e93bce03c78dbe1907ea5edfcd
+DIST gigolo-0.5.4.tar.bz2 507720 BLAKE2B 7fafd21dc25e3654ac3e0fa71a35ddabdba24dce1b41cfa8c3bfb26a5c32c08eba360b0f9fbbb5ef00d0206d402a3e0ed2adf1847f95059dc325915777b65fe4 SHA512 39802369b53f764394914ce40477ba51f8eb00089f2fb6ffe6eb590e797de0662ff84bbcac9fdfa532c54cb293f1482d4fa8a1282aa82991b6b36d2e8a5a3b0f
EBUILD gigolo-0.5.3.ebuild 824 BLAKE2B 90e60acd01281eed417f5e623773dbcdd1936a367cce21e7a4b32a12fc40b42d16f83351bb73ad0be6487f7809005bd5e19afb61b357a15e3d3cec7bcd872903 SHA512 982b39875865d59f3291fc91f69abb7fca31beac5f0c9c315b3f22d061cc73a23bca2eb49dbd07b852cb2a9a02230b91a6cf41650f53e98d84cf0c8ae039db71
+EBUILD gigolo-0.5.4.ebuild 808 BLAKE2B ca7ec5f35e6c5815730ddc525e57ef4b979a2ec6bf002b695194964723f0eacf010987279c2f2966bffe1c7f3eea08fcdf59c58be5cc4d7ac4591efeb53b9642 SHA512 79bcaac8469839e2827240644966b45378a89e7d48d5b1a3961aacb08a8ad997de63096b410912286f5ba0b318f2c73041eca3085362dcff339dc2aab85860d2
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/x11-misc/gigolo/gigolo-0.5.4.ebuild b/x11-misc/gigolo/gigolo-0.5.4.ebuild
new file mode 100644
index 000000000000..f4682bb4beae
--- /dev/null
+++ b/x11-misc/gigolo/gigolo-0.5.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A frontend to easily manage connections to remote filesystems using GIO/GVfs"
+HOMEPAGE="
+ https://docs.xfce.org/apps/gigolo/start
+ https://gitlab.xfce.org/apps/gigolo/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.38.0
+ >=x11-libs/gtk+-3.14.0:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ rm COPYING || die
+ default
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}