summaryrefslogtreecommitdiff
path: root/x11-misc/gromit/gromit-20041213-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/gromit/gromit-20041213-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/gromit/gromit-20041213-r1.ebuild')
-rw-r--r--x11-misc/gromit/gromit-20041213-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/gromit/gromit-20041213-r1.ebuild b/x11-misc/gromit/gromit-20041213-r1.ebuild
new file mode 100644
index 000000000000..e14be1452ea6
--- /dev/null
+++ b/x11-misc/gromit/gromit-20041213-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="GRaphics Over MIscellaneous Things, a presentation helper"
+HOMEPAGE="http://www.home.unix-ag.org/simon/gromit"
+SRC_URI="http://www.home.unix-ag.org/simon/gromit/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin ${PN}
+ newdoc ${PN}rc ${PN}rc.example
+ einstalldocs
+}