summaryrefslogtreecommitdiff
path: root/x11-misc/grub2-theme-preview/grub2-theme-preview-2.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /x11-misc/grub2-theme-preview/grub2-theme-preview-2.5.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'x11-misc/grub2-theme-preview/grub2-theme-preview-2.5.0.ebuild')
-rw-r--r--x11-misc/grub2-theme-preview/grub2-theme-preview-2.5.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/grub2-theme-preview/grub2-theme-preview-2.5.0.ebuild b/x11-misc/grub2-theme-preview/grub2-theme-preview-2.5.0.ebuild
new file mode 100644
index 000000000000..9c69943a3a53
--- /dev/null
+++ b/x11-misc/grub2-theme-preview/grub2-theme-preview-2.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Preview a GRUB 2.x theme using KVM/QEMU"
+HOMEPAGE="https://github.com/hartwork/grub2-theme-preview"
+SRC_URI="https://github.com/hartwork/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="grub_platforms_efi-64"
+
+RDEPEND="app-emulation/qemu
+ dev-libs/libisoburn
+ sys-fs/mtools
+ grub_platforms_efi-64? (
+ sys-boot/grub:2[grub_platforms_efi-64]
+ sys-firmware/edk2-ovmf
+ )
+ !grub_platforms_efi-64? (
+ sys-boot/grub:2[grub_platforms_pc]
+ )
+"
+DEPEND="test? ( dev-python/parameterized[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest