summaryrefslogtreecommitdiff
path: root/x11-misc/imake/imake-1.0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-09 01:01:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-09 01:01:10 +0000
commit7a808196491672645bab84bf994294bfcf1dd394 (patch)
tree802cfbfead9c2426a34b9ae4908b3da5c37b719a /x11-misc/imake/imake-1.0.10.ebuild
parent1e1e7636b59380beebd325e8d256875e4f824230 (diff)
gentoo auto-resync : 09:01:2024 - 01:01:10
Diffstat (limited to 'x11-misc/imake/imake-1.0.10.ebuild')
-rw-r--r--x11-misc/imake/imake-1.0.10.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-misc/imake/imake-1.0.10.ebuild b/x11-misc/imake/imake-1.0.10.ebuild
new file mode 100644
index 000000000000..db1832b81b79
--- /dev/null
+++ b/x11-misc/imake/imake-1.0.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+XORG_TARBALL_SUFFIX="xz"
+inherit toolchain-funcs xorg-3
+
+DESCRIPTION="C preprocessor interface to the make utility"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="x11-misc/xorg-cf-files"
+DEPEND="x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.8-cpp-args.patch
+ "${FILESDIR}"/${PN}-1.0.9-no-get-gcc.patch
+ "${FILESDIR}"/${PN}-1.0.8-respect-LD.patch
+ "${FILESDIR}"/${PN}-1.0.8-xmkmf-pass-cc-ld.patch
+)
+
+src_configure() {
+ econf CPP="$(tc-getPROG CPP cpp)" #722046
+}