summaryrefslogtreecommitdiff
path: root/x11-misc/lsw/lsw-0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/lsw/lsw-0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/lsw/lsw-0.3.ebuild')
-rw-r--r--x11-misc/lsw/lsw-0.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/lsw/lsw-0.3.ebuild b/x11-misc/lsw/lsw-0.3.ebuild
new file mode 100644
index 000000000000..09db83b1ff03
--- /dev/null
+++ b/x11-misc/lsw/lsw-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="list window names"
+HOMEPAGE="https://tools.suckless.org/x/lsw"
+SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ sed -i config.mk \
+ -e '/^CC/d' \
+ -e '/^CFLAGS/{s| -Os||;s|=|+=|}' \
+ -e '/^LDFLAGS/{s|=|+=|;s| -s||}' || die
+ sed -i \
+ -e 's|^\t@|\t|g' \
+ -e '/^\techo/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ doman ${PN}.1
+ dobin ${PN}
+}