summaryrefslogtreecommitdiff
path: root/x11-misc/mozo/mozo-1.26.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-22 07:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-22 07:49:59 +0000
commit591f45259704c7c0c4289228107c6ee61457420e (patch)
tree5e8d5d28f7699a5b31d1c2b112b2bb84fe36bc42 /x11-misc/mozo/mozo-1.26.1.ebuild
parent9f4b8d7fbdb3e35f8854c2e1c63926e383d299ea (diff)
gentoo auto-resync : 22:12:2023 - 07:49:59
Diffstat (limited to 'x11-misc/mozo/mozo-1.26.1.ebuild')
-rw-r--r--x11-misc/mozo/mozo-1.26.1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/x11-misc/mozo/mozo-1.26.1.ebuild b/x11-misc/mozo/mozo-1.26.1.ebuild
deleted file mode 100644
index 145332a6ed9f..000000000000
--- a/x11-misc/mozo/mozo-1.26.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit mate python-r1
-
-DESCRIPTION="Mozo menu editor for MATE"
-LICENSE="GPL-2+ GPL-3+ LGPL-2+ LGPL-2.1+"
-
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-COMMON_DEPEND="${PYTHON_DEPS}
- >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
- >=mate-base/mate-menus-1.21.0[introspection]
- x11-libs/gdk-pixbuf:2[introspection]
- >=x11-libs/gtk+-3.22:3[introspection]
- !!x11-misc/mate-menu-editor
-"
-
-RDEPEND="${COMMON_DEPEND}
- virtual/libintl
-"
-DEPEND="${COMMON_DEPEND}
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
-"
-
-src_prepare() {
- mate_src_prepare
- python_copy_sources
-}
-
-src_configure() {
- python_foreach_impl run_in_build_dir mate_src_configure \
- --disable-icon-update
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_test() {
- python_foreach_impl run_in_build_dir emake check
-}
-
-src_install() {
- installing() {
- mate_src_install
-
- # Massage shebang to make python_doscript happy
- sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
- -i mozo || die
-
- python_doscript mozo
- python_optimize
- }
-
- python_foreach_impl run_in_build_dir installing
-}