summaryrefslogtreecommitdiff
path: root/x11-misc/mozo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-05 11:30:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-05 11:30:40 +0100
commit3023707d355581e5dc6945aa9c8f4d59e508a8b5 (patch)
tree5bf569d557ba145002d922f72eadde17410572d4 /x11-misc/mozo
parent4e777c0133d093c9c8b992c92e0f244e2055bf71 (diff)
gentoo auto-resync : 05:05:2023 - 11:30:40
Diffstat (limited to 'x11-misc/mozo')
-rw-r--r--x11-misc/mozo/Manifest2
-rw-r--r--x11-misc/mozo/mozo-1.26.2.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/x11-misc/mozo/Manifest b/x11-misc/mozo/Manifest
index 624d0eb25cac..4521c2a5ee9b 100644
--- a/x11-misc/mozo/Manifest
+++ b/x11-misc/mozo/Manifest
@@ -1,3 +1,5 @@
DIST mozo-1.26.1.tar.xz 242836 BLAKE2B 59047b087e531792c0e831779d06a2dc7d9d2709bef7a7c8ba4a21d6f9fe1a79f917e2ba4e4912d655ad94391c0f7789e6ad6394be1a7bcb482881781f81c9ff SHA512 8570db4719d88bb34269a23acaa63638c5b7e50bf840bca73db718040c9d585670f1fd3be128c51ff22b4314f59dad6050907db8ce60bb506e4d46c3f807707e
+DIST mozo-1.26.2.tar.xz 249672 BLAKE2B 95e9a04fc91424e8ce95e870253bf1d2eddfbbf1b78b632b15d057a3ffa86068bb2c89442cfc50c4f74a76e75b345c6b06cf47d5891eed3ffce460697fb0094b SHA512 c4ea00f97f4dd5c9b33b78e1b438ba80a5e23b69d05f6ea59c522a580c1b07c280cddc0591f266c16f39bbe5f3e07ca28cdbd33753162a02584b551a9857b904
EBUILD mozo-1.26.1.ebuild 1284 BLAKE2B 4acc6d08a9ce787d6363b44e21d271ff57ee88386ae509b3f74fd7e1d4c533f4839e5010c897151b1bc19c2e4d030407efa0624127668f12ce415fc777d908bd SHA512 62e2a3c2fe6514e145d0068c26731ec829e19faf4590af2e20ceb8ecbb62733ecd6988a52f88d4c719983c225a713456fecf1765ad2e5b84781bc19f888cd3b3
+EBUILD mozo-1.26.2.ebuild 1258 BLAKE2B 0aa0fa4820c3984dad7abc7dbb3ba7fb7d725ad40952d13169d524a7153d19e1cc75f91438158e4c60ca1dae51101a90ccb808e44dc33b46f3fd3818ed8f2bce SHA512 c290edf6a86786698a0838f79894a7d0a79358ddd071fa8049a022dde3931c386e1df3ab88b059caae18eb21aa6e0d33e7a2c3ae28270c04f11e1722a4d23774
MISC metadata.xml 334 BLAKE2B 2d3b282a39f97386fb0986f460903c132a59464c1f408bcf1e081198aa07ff38cdd50fe460d2bb20a2dd17ccd6a6d7e49b31d5615b892591466a019001bd5727 SHA512 d04ccb64388d150947f281085fe3c70e5285d56518eb6359bb81d533fbaf2a44aee23e2d3f04896bbe15df07a5260a688949ed8505b9c87a857fc0882a425d74
diff --git a/x11-misc/mozo/mozo-1.26.2.ebuild b/x11-misc/mozo/mozo-1.26.2.ebuild
new file mode 100644
index 000000000000..29f2da4774bc
--- /dev/null
+++ b/x11-misc/mozo/mozo-1.26.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit mate python-r1
+
+DESCRIPTION="Mozo menu editor for MATE"
+LICENSE="GPL-2+ GPL-3+ LGPL-2+ LGPL-2.1+"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=mate-base/mate-menus-1.21.0[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.12:3[introspection]
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ mate_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir mate_src_configure \
+ --disable-icon-update
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir emake check
+}
+
+src_install() {
+ installing() {
+ mate_src_install
+
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i mozo || die
+
+ python_doscript mozo
+ python_optimize
+ }
+
+ python_foreach_impl run_in_build_dir installing
+}