summaryrefslogtreecommitdiff
path: root/x11-misc/obconf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /x11-misc/obconf
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'x11-misc/obconf')
-rw-r--r--x11-misc/obconf/Manifest3
-rw-r--r--x11-misc/obconf/obconf-2.0.4_p20150213.ebuild48
-rw-r--r--x11-misc/obconf/obconf-9999.ebuild41
3 files changed, 50 insertions, 42 deletions
diff --git a/x11-misc/obconf/Manifest b/x11-misc/obconf/Manifest
index acab6189146e..6a8369ddce4c 100644
--- a/x11-misc/obconf/Manifest
+++ b/x11-misc/obconf/Manifest
@@ -1,4 +1,5 @@
DIST obconf-2.0.4.tar.gz 456523 BLAKE2B ef3b3e4664ccd1095f5e1cd468fa3d021cd469a641930309a41c7b1cf418b9d87b2d8f4420342363dc4781d8e3aca3e8ffc0b9aac0151a2399579c5ff0997cc8 SHA512 b8cf6f363fa8c2f1d21142a3f79687a72f683f564285b05751c822ddf7a421b09c3440cbc5b08eb09d151601c6ada835ff5cc940bf5abeec2210cca26b552294
+DIST obconf-2.0.4_p20150213.tar.gz 154638 BLAKE2B 9ff9d206b8f789d2c7bf68f6f959f34d19f368645bc4efb77b5a730a8f69db5309ddecc0afb09e7cd2f9cb2af4e705112f3365f43dfbe94c4ff523d8a7f0dff5 SHA512 987c97729b248e9d9fb4c82a131517ee8f31df5dd455b5b658730204c354bf17f7876c269c1d1ec6497ca360698a393c7275b9e7ada5b31abb75ed7b06092e30
EBUILD obconf-2.0.4.ebuild 800 BLAKE2B 7b1347909fae8830eef9781a31126397e857fee02769a8cf719fc2db8bba8678c49e19e4e0372ce7c3fbdd91a4b44fa3412535e5d7e5c2d37276005ca0f50d6c SHA512 a74608f458dc0d372cd5ce8f9137ed53a283babb2696bc3e76ec4b93d0279267cf695f220c0899c33c25639c34125c3e754972615a6a297ee5af638204b58ef1
-EBUILD obconf-9999.ebuild 767 BLAKE2B 83d6d4c188108b33926b8afa8f1115a00dff7fb0ac2d3f4ccd94f0930567305ca2bd626f5159ed5e0683a6b2619e9bf6b0c6f563268a7db6be2bb218a861a364 SHA512 cc71a7f24edc705f8155ddc52e368027beef8bce3f5abc063ff1a7a6f71e8baa0bdddbcd66d95a79be6a64b682d27b8aa607771bd6ce90abbefaf667072cf71c
+EBUILD obconf-2.0.4_p20150213.ebuild 983 BLAKE2B 3d534b9bb0647112d086c20b5b3820d18198740cef818eefb67eb8ed1cc2cf397690d5c846482bda19ee201521d137c4fec67486a66ed1e24cf344f2ea2e0b7c SHA512 6d6052a0b24da24783991d1f0e047c5470006b4fdc52c8569d87577a615c50d9b0112caeff64d4ca834c5fee9d0ffd93e3ddedc675e96c0c9451ec7bf3afdb85
MISC metadata.xml 245 BLAKE2B 26bf988c73d073000ab8d21ea881c4088b90e7081410938828744375bfa8de31cce2c78154ccfc61105c853c1f24f4994ca4e5cbb80c4c89dfd489bbd10a09ee SHA512 ecb8a4621081ccdd43f08e4f560b0bc820c27d6a282c87e1a8f77137ec8b215188fe31f11fc6379533afee2ebe7e14d5395a45c1aab9abfe423fd832dba692a4
diff --git a/x11-misc/obconf/obconf-2.0.4_p20150213.ebuild b/x11-misc/obconf/obconf-2.0.4_p20150213.ebuild
new file mode 100644
index 000000000000..b20d7f915a06
--- /dev/null
+++ b/x11-misc/obconf/obconf-2.0.4_p20150213.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT=63ec47c5e295ad4f09d1df6d92afb7e10c3fec39
+inherit autotools xdg-utils
+
+DESCRIPTION="Tool for configuring the Openbox window manager"
+HOMEPAGE="http://openbox.org/wiki/ObConf:About"
+SRC_URI="http://git.openbox.org/?p=dana/obconf.git;a=snapshot;h=${COMMIT};sf=tgz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT:0:7}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE="nls"
+
+RDEPEND="
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/startup-notification
+ >=x11-wm/openbox-3.5.2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/x11-misc/obconf/obconf-9999.ebuild b/x11-misc/obconf/obconf-9999.ebuild
deleted file mode 100644
index 182f34ce49f0..000000000000
--- a/x11-misc/obconf/obconf-9999.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools xdg-utils git-r3
-
-DESCRIPTION="ObConf is a tool for configuring the Openbox window manager"
-HOMEPAGE="http://openbox.org/wiki/ObConf:About"
-EGIT_REPO_URI="git://git.openbox.org/dana/obconf.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="nls"
-
-RDEPEND="x11-libs/gtk+:3
- x11-libs/startup-notification
- =x11-wm/openbox-9999"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable nls)
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}