summaryrefslogtreecommitdiff
path: root/x11-misc/rofi/rofi-1.7.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-16 14:04:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-16 14:04:41 +0000
commitb18dbdc69b2be6f0ac0db668b0bc57fb6f766afc (patch)
treee77939b82c93b9689bc1bb0bc8a55132c509cb44 /x11-misc/rofi/rofi-1.7.5.ebuild
parent97f40b36b1afa9726e32962d11f3ac2d0bc5792e (diff)
gentoo auto-resync : 16:02:2023 - 14:04:41
Diffstat (limited to 'x11-misc/rofi/rofi-1.7.5.ebuild')
-rw-r--r--x11-misc/rofi/rofi-1.7.5.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/x11-misc/rofi/rofi-1.7.5.ebuild b/x11-misc/rofi/rofi-1.7.5.ebuild
index c51049b5e10e..8e9a841cca71 100644
--- a/x11-misc/rofi/rofi-1.7.5.ebuild
+++ b/x11-misc/rofi/rofi-1.7.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,11 +7,17 @@ inherit autotools toolchain-funcs xdg-utils
DESCRIPTION="A window switcher, run dialog and dmenu replacement"
HOMEPAGE="https://github.com/davatorium/rofi"
-SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.xz"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/davatorium/rofi"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 arm64 x86"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 arm64 x86"
IUSE="+drun test +windowmode"
RESTRICT="!test? ( test )"
@@ -48,6 +54,9 @@ src_configure() {
# Doesn't work with reflex, bug #887049
export LEX=flex
+ # Requires bison, see https://bugs.gentoo.org/894634.
+ unset YACC
+
tc-export CC
local myeconfargs=(
@@ -59,15 +68,6 @@ src_configure() {
}
pkg_postinst() {
- for v in ${REPLACING_VERSIONS}; do
- if ver_test "${v}" -lt 1.7.0; then
- elog "Rofi 1.7.0 removed the (deprecated) xresources based configuration setup."
- elog "If you are still using old configuration setup, please convert it to new format manually."
- elog "The new format configuration can be generated by 'rofi -dump-config > ~/.config/rofi/config.rasi'."
- elog "For more information, please see https://github.com/davatorium/rofi/releases/tag/1.7.0"
- fi
- done
-
xdg_icon_cache_update
}