summaryrefslogtreecommitdiff
path: root/x11-misc/safeeyes/safeeyes-2.1.6-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-03 16:59:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-03 16:59:44 +0000
commitc62565378cd5a3feb54906f6458ca268db51a31a (patch)
tree7be47f380dd4086217e29f905280ab4d1d3bd2bc /x11-misc/safeeyes/safeeyes-2.1.6-r2.ebuild
parent09abaf880cd5b1ca2d0d7c320780f91fb3a0428f (diff)
gentoo auto-resync : 03:12:2023 - 16:59:43
Diffstat (limited to 'x11-misc/safeeyes/safeeyes-2.1.6-r2.ebuild')
-rw-r--r--x11-misc/safeeyes/safeeyes-2.1.6-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/safeeyes-2.1.6-r2.ebuild b/x11-misc/safeeyes/safeeyes-2.1.6-r2.ebuild
new file mode 100644
index 000000000000..307103b60daf
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.1.6-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="tk" # for site-packages/Xlib/ext/randr.py
+DISTUTILS_USE_PEP517=setuptools
+
+inherit xdg distutils-r1 pypi
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-py312.patch
+)
+
+RDEPEND="
+ dev-libs/libayatana-appindicator
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}