summaryrefslogtreecommitdiff
path: root/x11-misc/sddm/sddm-0.15.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /x11-misc/sddm/sddm-0.15.0-r2.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'x11-misc/sddm/sddm-0.15.0-r2.ebuild')
-rw-r--r--x11-misc/sddm/sddm-0.15.0-r2.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/x11-misc/sddm/sddm-0.15.0-r2.ebuild b/x11-misc/sddm/sddm-0.15.0-r2.ebuild
deleted file mode 100644
index 6c3a8e611fc2..000000000000
--- a/x11-misc/sddm/sddm-0.15.0-r2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils systemd user
-
-DESCRIPTION="Simple Desktop Display Manager"
-HOMEPAGE="https://github.com/sddm/sddm"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-LICENSE="GPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0 public-domain"
-SLOT="0"
-IUSE="elogind +pam systemd"
-
-REQUIRED_USE="?? ( elogind systemd )"
-
-RDEPEND="
- >=dev-qt/qtcore-5.6:5
- >=dev-qt/qtdbus-5.6:5
- >=dev-qt/qtgui-5.6:5
- >=dev-qt/qtdeclarative-5.6:5
- >=dev-qt/qtnetwork-5.6:5
- >=x11-base/xorg-server-1.15.1
- x11-libs/libxcb[xkb]
- elogind? ( sys-auth/elogind )
- pam? ( sys-libs/pam )
- !pam? ( virtual/libcrypt:= )
- systemd? ( sys-apps/systemd:= )
- !systemd? ( sys-power/upower )"
-
-DEPEND="${RDEPEND}
- dev-python/docutils
- >=dev-qt/linguist-tools-5.6:5
- >=dev-qt/qttest-5.6:5
- kde-frameworks/extra-cmake-modules
- virtual/pkgconfig"
-
-# fix for flags handling and bug 563108
-PATCHES=( "${FILESDIR}/${PN}-0.12.0-respect-user-flags.patch" )
-
-src_prepare() {
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_PAM=$(usex pam)
- -DNO_SYSTEMD=$(usex '!systemd')
- -DUSE_ELOGIND=$(usex 'elogind')
- -DBUILD_MAN_PAGES=ON
- -DDBUS_CONFIG_FILENAME="org.freedesktop.sddm.conf"
- )
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 /var/lib/${PN} ${PN},video
-
- systemd_reenable sddm.service
-}