summaryrefslogtreecommitdiff
path: root/x11-misc/skippy/skippy-0.5.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/skippy/skippy-0.5.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/skippy/skippy-0.5.0-r1.ebuild')
-rw-r--r--x11-misc/skippy/skippy-0.5.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/skippy/skippy-0.5.0-r1.ebuild b/x11-misc/skippy/skippy-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..e2823f2dfb16
--- /dev/null
+++ b/x11-misc/skippy/skippy-0.5.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="A full-screen task-switcher providing Apple Expose-like functionality"
+HOMEPAGE="http://thegraveyard.org/skippy.php"
+SRC_URI="http://thegraveyard.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="media-libs/imlib2[X]
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXinerama
+ x11-libs/libXmu
+ x11-libs/libXft"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xineramaproto
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-pointer-size.patch
+ "${FILESDIR}"/${P}-Makefile.patch
+)
+
+DOCS=( CHANGELOG skippyrc-default )
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+pkg_postinst() {
+ elog
+ elog "You should copy skippyrc-default from /usr/share/doc/${PF} to"
+ elog "~/.skippyrc and edit the keysym used to invoke skippy."
+ elog "Use x11-apps/xev to find out the keysym."
+ elog
+}