summaryrefslogtreecommitdiff
path: root/x11-misc/stalonetray/stalonetray-0.8.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /x11-misc/stalonetray/stalonetray-0.8.4.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'x11-misc/stalonetray/stalonetray-0.8.4.ebuild')
-rw-r--r--x11-misc/stalonetray/stalonetray-0.8.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/stalonetray/stalonetray-0.8.4.ebuild b/x11-misc/stalonetray/stalonetray-0.8.4.ebuild
new file mode 100644
index 000000000000..602d6943d3ad
--- /dev/null
+++ b/x11-misc/stalonetray/stalonetray-0.8.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="System tray utility including support for KDE system tray icons"
+HOMEPAGE="https://stalonetray.github.io/"
+SRC_URI="https://github.com/kolbusa/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +graceful-exit"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="app-text/docbook-xml-dtd
+ dev-libs/libxslt"
+
+DOCS=( AUTHORS BUGS COPYING NEWS README.md TODO stalonetrayrc.sample stalonetray.html )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable graceful-exit) \
+ --enable-native-kde
+}
+
+src_compile() {
+ emake
+ emake dist
+}