summaryrefslogtreecommitdiff
path: root/x11-misc/stalonetray/stalonetray-0.8.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-20 16:18:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-20 16:18:45 +0100
commit2ffbfc63824a9e437090fb3c744670dd45369ae0 (patch)
treead31a5650e31f93490157943681bb982f8a4520c /x11-misc/stalonetray/stalonetray-0.8.5.ebuild
parent399fa07bfac673a8846466b16c76549e329b55b8 (diff)
gentoo auto-resync : 20:05:2023 - 16:18:45
Diffstat (limited to 'x11-misc/stalonetray/stalonetray-0.8.5.ebuild')
-rw-r--r--x11-misc/stalonetray/stalonetray-0.8.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/stalonetray/stalonetray-0.8.5.ebuild b/x11-misc/stalonetray/stalonetray-0.8.5.ebuild
new file mode 100644
index 000000000000..15991a24a54d
--- /dev/null
+++ b/x11-misc/stalonetray/stalonetray-0.8.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="System tray utility including support for KDE system tray icons"
+HOMEPAGE="https://kolbusa.github.io/stalonetray/"
+SRC_URI="https://github.com/kolbusa/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="debug +graceful-exit"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="app-text/docbook-xml-dtd
+ dev-libs/libxslt"
+
+DOCS=( AUTHORS BUGS COPYING NEWS README.md TODO stalonetrayrc.sample stalonetray.html )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable graceful-exit) \
+ --enable-native-kde
+}
+
+src_compile() {
+ emake
+ emake dist
+}