summaryrefslogtreecommitdiff
path: root/x11-misc/superswitcher/superswitcher-0.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/superswitcher/superswitcher-0.6-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/superswitcher/superswitcher-0.6-r1.ebuild')
-rw-r--r--x11-misc/superswitcher/superswitcher-0.6-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/superswitcher/superswitcher-0.6-r1.ebuild b/x11-misc/superswitcher/superswitcher-0.6-r1.ebuild
new file mode 100644
index 000000000000..63e4756b5b18
--- /dev/null
+++ b/x11-misc/superswitcher/superswitcher-0.6-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A more feature-full replacement of the Alt-Tab window switching behavior"
+HOMEPAGE="https://code.google.com/p/superswitcher/"
+SRC_URI="https://superswitcher.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ >=gnome-base/gconf-2:2
+ x11-libs/gtk+:2
+ >=x11-libs/libwnck-2.10:1
+ x11-libs/libXcomposite
+ x11-libs/libXinerama
+ x11-libs/libXrender"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-wnck-workspace.patch
+ "${FILESDIR}"/${PN}-0.6-glib-single-include.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/-DG.*_DISABLE_DEPRECATED/d' \
+ src/Makefile.am || die #338906
+
+ mv configure.{in,ac} || die #426262
+
+ eautoreconf
+}