summaryrefslogtreecommitdiff
path: root/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild')
-rw-r--r--x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild b/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild
new file mode 100644
index 000000000000..67c06dc2d15d
--- /dev/null
+++ b/x11-misc/sw-notify-send/sw-notify-send-1.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_P=tinynotify-send-${PV}
+DESCRIPTION="A system-wide variant of tinynotify-send"
+HOMEPAGE="https://github.com/mgorny/tinynotify-send/"
+SRC_URI="https://github.com/mgorny/tinynotify-send/releases/download/${MY_P}/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libtinynotify:0=
+ ~x11-libs/libtinynotify-cli-${PV}
+ x11-libs/libtinynotify-systemwide:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README )
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local myconf=(
+ --disable-library
+ --disable-regular
+ --enable-system-wide
+ )
+
+ econf "${myconf[@]}"
+}