summaryrefslogtreecommitdiff
path: root/x11-misc/sxcs/sxcs-0.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-17 20:06:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-17 20:06:58 +0000
commit08c5e4df7a4b66ba8dbb827ca2e3a973d4f19ab0 (patch)
tree347af25df153363454776e1fe95fc4e8100a7e7d /x11-misc/sxcs/sxcs-0.7.3.ebuild
parentfc6e577018dec28e18904f9ad5c1417976e3c728 (diff)
gentoo auto-resync : 17:01:2024 - 20:06:58
Diffstat (limited to 'x11-misc/sxcs/sxcs-0.7.3.ebuild')
-rw-r--r--x11-misc/sxcs/sxcs-0.7.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/sxcs/sxcs-0.7.3.ebuild b/x11-misc/sxcs/sxcs-0.7.3.ebuild
new file mode 100644
index 000000000000..0ffac067fd37
--- /dev/null
+++ b/x11-misc/sxcs/sxcs-0.7.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Color picker and magnifier for X11"
+HOMEPAGE="https://codeberg.org/NRK/sxcs"
+
+SRC_URI="https://codeberg.org/NRK/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+KEYWORDS="~amd64"
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXcursor
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ $(tc-getCC) -o sxcs sxcs.c ${CFLAGS} ${LDFLAGS} -l X11 -l Xcursor || die "Compilation failed"
+}
+
+src_install() {
+ dobin sxcs
+ doman sxcs.1
+ dodoc README.md
+}