summaryrefslogtreecommitdiff
path: root/x11-misc/sxhkd/sxhkd-0.6.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /x11-misc/sxhkd/sxhkd-0.6.2-r1.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'x11-misc/sxhkd/sxhkd-0.6.2-r1.ebuild')
-rw-r--r--x11-misc/sxhkd/sxhkd-0.6.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/sxhkd/sxhkd-0.6.2-r1.ebuild b/x11-misc/sxhkd/sxhkd-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..83ed6a4db2ef
--- /dev/null
+++ b/x11-misc/sxhkd/sxhkd-0.6.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs systemd
+
+DESCRIPTION="Simple X hotkey daemon"
+HOMEPAGE="https://github.com/baskerville/sxhkd/"
+SRC_URI="https://github.com/baskerville/sxhkd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~riscv x86"
+
+RDEPEND="
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-keysyms"
+DEPEND="
+ ${RDEPEND}
+ x11-libs/xcb-util"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCPREFIX="${EPREFIX}"/usr/share/doc/${PF}
+ )
+ emake "${emakeargs[@]}" install
+
+ systemd_dounit contrib/systemd/${PN}.service
+}