summaryrefslogtreecommitdiff
path: root/x11-misc/tabbed/tabbed-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/tabbed/tabbed-0.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/tabbed/tabbed-0.6.ebuild')
-rw-r--r--x11-misc/tabbed/tabbed-0.6.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/tabbed/tabbed-0.6.ebuild b/x11-misc/tabbed/tabbed-0.6.ebuild
new file mode 100644
index 000000000000..62c051535985
--- /dev/null
+++ b/x11-misc/tabbed/tabbed-0.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="Simple generic tabbed fronted to xembed aware applications"
+HOMEPAGE="https://tools.suckless.org/tabbed"
+SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="
+ x11-proto/xproto
+ ${RDEPEND}
+"
+
+src_prepare() {
+ sed config.mk \
+ -e '/^CC/d' \
+ -e 's|/usr/local|/usr|g' \
+ -e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)|g' \
+ -e 's|^LDFLAGS.*|LDFLAGS += $(CFLAGS) $(LIBS)|g' \
+ -e 's|^LIBS.*|LIBS = -lX11|g' \
+ -e 's|{|(|g;s|}|)|g' \
+ -i || die
+
+ sed Makefile \
+ -e 's|{|(|g;s|}|)|g' \
+ -e '/^[[:space:]]*@echo/d' \
+ -e 's|^ @| |g' \
+ -i || die
+
+ restore_config config.h
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+src_install() {
+ default
+ save_config config.h
+}