summaryrefslogtreecommitdiff
path: root/x11-misc/trayer-srg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /x11-misc/trayer-srg
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'x11-misc/trayer-srg')
-rw-r--r--x11-misc/trayer-srg/Manifest2
-rw-r--r--x11-misc/trayer-srg/trayer-srg-1.1.8.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/trayer-srg/Manifest b/x11-misc/trayer-srg/Manifest
index f4883d21a3c4..cf738c9f6a58 100644
--- a/x11-misc/trayer-srg/Manifest
+++ b/x11-misc/trayer-srg/Manifest
@@ -1,3 +1,5 @@
DIST trayer-srg-1.1.7.tar.gz 27987 BLAKE2B aaaa1609bebe91c7b2d3934d68075fa16f393896b7f9300dd6aecd7aa8666a7f3474711fbbc9dae5f72ed5ba8b63d0275f590a5a82ea4547b640a75a81012fc5 SHA512 5bb049af01c3f3f62dc8a5c1932985b92c98e4e2083aebd1dc09256746e097239be54ebc739801773878882a5c8f168a4a13bdac292388f79079ad52c41b2cad
+DIST trayer-srg-1.1.8.tar.gz 28025 BLAKE2B 3eca8faf7237e1941a611a85a4460310dda1a8d89cb96ae2ac7d77c47a7f8b4fa4bb1a2bcc549fef285ca14a74dce23d9af1b349bb5b0ff9d3bf4abe1ed06351 SHA512 5ae92fdcee64ad1ca59846874dcd4bd4859adeeb80a86f1ed97d62e6306f8ec62d1ee26dba251257242dc25d158a6a550e69f2fcc8739242a2311e37fe1ce310
EBUILD trayer-srg-1.1.7.ebuild 751 BLAKE2B ca5874b16f3a731b57227673e02877d726c0ab61a71c52877bbb03201c4fc3bb81103a433dc0efebe2c65721e05552f193befacedc98864a4214a921df76bc89 SHA512 99772b9da40ea7b900826842aed0423cc0196f1e7eb6b7c033cadc896e5751d29eb327384a923179f9e624ce57a03f1500c9164f13800c6e98ad09ec9a9838d7
+EBUILD trayer-srg-1.1.8.ebuild 753 BLAKE2B a3168f1b77ac80cde3aa9fc3fb3815c0693102851497c205ea057493c9fe3d1d39f5db0e19e1fb37667238b1047b9a1c48150b178790693c6a9c157b98ab5f7f SHA512 cb976fd7a951a3ca4f3903a452f99ed1ea72dd251bf98a6550be72b94d6358b63a5181c0b0a437291ec0173560d0d529ed1b844df09a9b65ff7aa0eaf6293f58
MISC metadata.xml 249 BLAKE2B b308f3f4e67b02a37d7df053cda2ce801a2e355f212a680126aa3338811fc6127838aaceaafe156f9afb871de57a301056dd9af8d0cccd32fdc79e2abce4b56f SHA512 a354c9b99e5ee4dbc44e534e5764479ab0f2cac37ce7d9699f0bd668653352c25c630be27239a3a1c3e3ae391891df7c3855e08dac224b510f0feff0c060ea4f
diff --git a/x11-misc/trayer-srg/trayer-srg-1.1.8.ebuild b/x11-misc/trayer-srg/trayer-srg-1.1.8.ebuild
new file mode 100644
index 000000000000..8a9b9e21d068
--- /dev/null
+++ b/x11-misc/trayer-srg/trayer-srg-1.1.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="trayer fork with multi monitor support and cleaned up codebase"
+HOMEPAGE="https://github.com/sargon/trayer-srg"
+SRC_URI="https://github.com/sargon/${PN}/archive/${P/-srg/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}"/${PN}-trayer-${PV}
+
+src_configure() {
+ # Custom configure script
+ ./configure --prefix="${EPREFIX}" || die
+}
+
+src_compile() {
+ emake DEVEL=1 TARGET=${PN} CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}