summaryrefslogtreecommitdiff
path: root/x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-19 12:11:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-19 12:11:50 +0100
commitfe0961fc9674dd24a017f474a34c1edbbd005965 (patch)
treedfdf05888e0f5fff9c1faafe6eb0dd5d827b63e5 /x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild
parentbcd00c826070701606b0ccebf46234dfc792d3e9 (diff)
gentoo auto-resync : 19:09:2024 - 12:11:50
Diffstat (limited to 'x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild')
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild b/x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild
new file mode 100644
index 000000000000..4688b3dae019
--- /dev/null
+++ b/x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GUILE_REQ_USE="deprecated"
+GUILE_COMPAT=( 2-2 3-0 )
+inherit autotools guile-single
+
+DESCRIPTION="Tool for launching commands on keystrokes"
+SRC_URI="https://www.nongnu.org/${PN}/${P}.tar.gz"
+HOMEPAGE="https://www.nongnu.org/xbindkeys/xbindkeys.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="guile tk"
+
+REQUIRED_USE="guile? ( ${GUILE_REQUIRED_USE} )"
+
+RDEPEND="
+ x11-libs/libX11
+ guile? ( ${GUILE_DEPS} )
+ tk? ( dev-lang/tk )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO xbindkeysrc )
+
+src_prepare() {
+ default
+
+ use guile && guile_bump_sources
+
+ # Regenerate to pick up newer versions of Guile macros
+ # bug #828532
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable guile) \
+ $(use_enable tk)
+}
+
+src_install() {
+ default
+
+ use guile && guile_unstrip_ccache
+}