summaryrefslogtreecommitdiff
path: root/x11-misc/xearth/xearth-1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-30 15:24:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-30 15:24:40 +0100
commit31459e63971ac3b08706bba949851d93c45043c3 (patch)
treef50f9db11363f1369a1aead733baccaf2842b673 /x11-misc/xearth/xearth-1.1-r1.ebuild
parenteba9b95ba8976f2938bafa5789c1b50611bb3459 (diff)
gentoo auto-resync : 30:09:2022 - 15:24:40
Diffstat (limited to 'x11-misc/xearth/xearth-1.1-r1.ebuild')
-rw-r--r--x11-misc/xearth/xearth-1.1-r1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11-misc/xearth/xearth-1.1-r1.ebuild b/x11-misc/xearth/xearth-1.1-r1.ebuild
index 542041ede4a8..d80d0c43e7eb 100644
--- a/x11-misc/xearth/xearth-1.1-r1.ebuild
+++ b/x11-misc/xearth/xearth-1.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,20 +18,23 @@ RDEPEND="
x11-libs/libX11
x11-libs/libXext
x11-libs/libXt"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
BDEPEND="
app-text/rman
- x11-base/xorg-proto
+ sys-devel/gcc
>=x11-misc/imake-1.0.8-r1"
PATCHES=(
"${FILESDIR}"/${P}-include.patch
)
+
DOCS=( BUILT-IN GAMMA-TEST HISTORY README )
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}
src_compile() {