summaryrefslogtreecommitdiff
path: root/x11-misc/xpad/xpad-5.8.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-25 15:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-25 15:53:45 +0000
commit83ebb477861172671f6796999e016400b659d65f (patch)
tree0cec26d10b5fcfee34cd56a952e8111f306feefb /x11-misc/xpad/xpad-5.8.0-r1.ebuild
parentbaeb826318951e5c82b18c1e9ee120ac5dcf0b94 (diff)
gentoo auto-resync : 25:02:2023 - 15:53:45
Diffstat (limited to 'x11-misc/xpad/xpad-5.8.0-r1.ebuild')
-rw-r--r--x11-misc/xpad/xpad-5.8.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/xpad/xpad-5.8.0-r1.ebuild b/x11-misc/xpad/xpad-5.8.0-r1.ebuild
new file mode 100644
index 000000000000..4c5b67b4ce67
--- /dev/null
+++ b/x11-misc/xpad/xpad-5.8.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg-utils
+
+DESCRIPTION="A sticky note application for GTK"
+HOMEPAGE="https://launchpad.net/xpad"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ >=dev-libs/glib-2.58:2
+ dev-libs/libayatana-appindicator
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3[X]
+ x11-libs/gtksourceview:4
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-util/intltool-0.31
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}