summaryrefslogtreecommitdiff
path: root/x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-13 21:03:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-13 21:03:07 +0100
commit8fbd420dce8836e6503b162092e07b6a77a89f1d (patch)
tree071c621ef44d7c1b24a430ac7671d68963b5a4cf /x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild
parent12d78242dec4f785d0a0bfb1c00eee2d8996c53b (diff)
gentoo resync : 13.10.2017
Diffstat (limited to 'x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild')
-rw-r--r--x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild b/x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild
new file mode 100644
index 000000000000..a7fea73b665d
--- /dev/null
+++ b/x11-misc/xsetleds/xsetleds-0.1.3-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="small tool to report and change the keyboard LED states of an X display"
+HOMEPAGE="https://github.com/bmeurer/xsetleds"
+SRC_URI="
+ ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/src/${P}.tar.gz
+ https://dev.gentoo.org/~jer/${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-assignment.patch
+ "${FILESDIR}"/${P}-isalpha.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+DOCS=( AUTHORS ChangeLog README TODO )