summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-14 06:41:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-14 06:41:38 +0000
commit6e1fc32629c46e29012a7e22b07085307d65ac96 (patch)
tree3a10753f21f24b2f29706bc4c28b1074119343d8 /x11-misc
parent4b1d73e089a436406c89fadc33638314981c44e6 (diff)
gentoo auto-resync : 14:01:2025 - 06:41:37
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/Manifest.gzbin46489 -> 46488 bytes
-rw-r--r--x11-misc/zim/Manifest2
-rw-r--r--x11-misc/zim/zim-0.76.0.ebuild86
3 files changed, 88 insertions, 0 deletions
diff --git a/x11-misc/Manifest.gz b/x11-misc/Manifest.gz
index a84751607bdb..596d21e1a0e3 100644
--- a/x11-misc/Manifest.gz
+++ b/x11-misc/Manifest.gz
Binary files differ
diff --git a/x11-misc/zim/Manifest b/x11-misc/zim/Manifest
index 0d66333fea47..86abc2f198ca 100644
--- a/x11-misc/zim/Manifest
+++ b/x11-misc/zim/Manifest
@@ -1,4 +1,6 @@
AUX zim-0.60-remove-ubuntu-theme.patch 669 BLAKE2B fbb3fe0082e7567f4ae9d0bd031096cf2bcbd4d4cb86b31ceff18dda880b5cf1f8441e452642dd28275c9ce6e20c7da0a3a77b4157da13d5d4bbe9b6a30a9086 SHA512 a2e202986c77490898c15f6c4e647667fd6662422e8bbd638624a52a33989cd4259f95b37f488ff4a947f04354704ee9df7b9d60aae2fcc928f1f3186955ea1a
DIST zim-0.75.2.tar.gz 3257345 BLAKE2B 452716cbc6c149645c5146d8fcef2449c7c316ac57da9870dbe26b9fec13b6827a6368295277dc3b2b7a7874a7c930da27612a8e8e00b295ae9ecb3942d0e65b SHA512 ea6f361047690dfb314a3510d34880a4831d142c94fc0ca08e1c29869fd42d5fd1182c47edc241edeb512fed601a474af6d9970f819e8a8b67135c7589ae461a
+DIST zim-0.76.0.tar.gz 3363266 BLAKE2B 36a34965ede3f544926bba515e66fdf6e1fbb211ecba96eaf9778f3e52cc6bacee5f03c91aadf0c4290f27b96e93fae450c3563c78be443e12aee84a5e0c65cb SHA512 f8504d936db7335a7f31c011b710e785ee58d2c9321e12dbd15848a4326ac24df7bc8069c4d2c8d07c2f537a694d9cf48be7acd36ab8a60b9ba35b4f3e094f8e
EBUILD zim-0.75.2-r1.ebuild 2045 BLAKE2B c6ab0541696c25bac4e415cf19ce12051030768ae1b9cfb226cf4b6d858d0e0c38c1cc1cfea9467387aa77800071b5ee634b80d6326a5a64471ca996db2df780 SHA512 3f7e04b8b94e4ad6fa8d35cb2064933a5af47e7b43fb37386018cfb1d2e8096e36752023979390a19767347e22d5ac3ea4d5543daa1790678745cd4220dde4c3
+EBUILD zim-0.76.0.ebuild 2156 BLAKE2B c5f6461b178c51aa9a0cc57d3bd4af85bc705d1e8e65f16258d08d295be465a3c18fc3602aae8415314b238a217c80c44d44980bf194f4e43e431d67387db9b5 SHA512 1a835b87426102bb4601248245f9822e3e9ecf5dc5265fd51be0a406a4d2aa621324b99342839249fd4501c667ad11e4105e6c7920e2e54565b6b7e63d810eaf
MISC metadata.xml 919 BLAKE2B 37f527c70451fc7a39ba04f55fcb87434de512a9250d97748a2e9e0e395dcdf0ab9ee81ba6894e104594da634ca3866b790d2916122a6380c92e011fc30187ec SHA512 e244bd3f10e24235d2072e8375255b698093aa0de8cd7720dabb8d64affcb6c91b256f0a21efef1041310be3d8680f598eca30b67813b661f5e8024ce28f24a2
diff --git a/x11-misc/zim/zim-0.76.0.ebuild b/x11-misc/zim/zim-0.76.0.ebuild
new file mode 100644
index 000000000000..bc5254db5c21
--- /dev/null
+++ b/x11-misc/zim/zim-0.76.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..13} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+VIRTUALX_REQUIRED=test
+inherit distutils-r1 optfeature virtualx xdg
+
+DESCRIPTION="A desktop wiki"
+HOMEPAGE="
+ https://zim-wiki.org/
+ https://github.com/zim-desktop-wiki/zim-desktop-wiki
+"
+SRC_URI="https://github.com/${PN}-desktop-wiki/${PN}-desktop-wiki/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${PN}-desktop-wiki-${PV/_/-}
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')
+ x11-libs/gtk+:3[introspection]
+ x11-misc/xdg-utils
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md PLUGIN_WRITING.md README.md )
+PATCHES=( "${FILESDIR}"/${PN}-0.60-remove-ubuntu-theme.patch )
+
+python_prepare_all() {
+ if [[ ${LINGUAS} ]]; then
+ local lingua
+ for lingua in translations/*.po; do
+ lingua=${lingua/.po}
+ lingua=${lingua/translations\/}
+ has ${lingua} ${LINGUAS} || \
+ { rm translations/${lingua}.po || die; }
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+ export XDG_RUNTIME_DIR=fakethis
+}
+
+python_compile() {
+ sed -e "s#./build#${BUILD_DIR}/build#" -i setup.py || die
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ if has_version dev-vcs/git; then
+ git config --global user.email "git@example.com" || die
+ git config --global user.name "GitExample" || die
+ fi
+
+ virtx ./test.py
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ insinto /usr/share/icons
+ doins -r xdg/hicolor
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "Spell checker" app-text/gtkspell[introspection]
+ optfeature "GNU R Plot Editor" dev-lang/R
+ optfeature "Version control Bazaar support" dev-vcs/breezy
+ optfeature "Diagram Editor" media-gfx/graphviz
+ optfeature "Insert Screenshot" "media-gfx/imagemagick media-gfx/scrot"
+ optfeature "Score Editor" media-sound/lilypond
+ optfeature "Gnuplot Editor" sci-visualization/gnuplot
+ optfeature "Equation Editor" virtual/latex-base app-text/dvipng
+}