summaryrefslogtreecommitdiff
path: root/x11-plugins/asapm/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/asapm/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/asapm/files')
-rw-r--r--x11-plugins/asapm/files/asapm-3.1-autoconf.patch21
-rw-r--r--x11-plugins/asapm/files/asapm-3.1-include.patch10
-rw-r--r--x11-plugins/asapm/files/asapm-3.1-ldflags.patch11
3 files changed, 42 insertions, 0 deletions
diff --git a/x11-plugins/asapm/files/asapm-3.1-autoconf.patch b/x11-plugins/asapm/files/asapm-3.1-autoconf.patch
new file mode 100644
index 000000000000..0051d49ac8a8
--- /dev/null
+++ b/x11-plugins/asapm/files/asapm-3.1-autoconf.patch
@@ -0,0 +1,21 @@
+--- a/autoconf/configure.in
++++ b/autoconf/configure.in
+@@ -59,7 +59,6 @@
+ AC_CHECK_HEADERS(sys/wait.h sys/time.h)
+ AC_CHECK_HEADERS(sys/statvfs.h sys/vfs.h sys/mount.h ustat.h)
+ AC_CHECK_HEADERS(machine/soundcard.h linux/soundcard.h linux/radio.h)
+-AC_CONFIG_HEADER(config.h)
+
+ dnl# Check for X
+
+@@ -117,10 +116,6 @@
+ AC_SUBST(with_gnustep_lib)
+ AC_SUBST(with_afterdir)
+
+-dnl# Write results
+-
+-AC_CONFIG_HEADER(config.h)
+-
+ dnl# Common parts of the Makefile
+ MAKEFILEDEFINES=./autoconf/Makefile.defines
+ MAKEFILECOMMON=./autoconf/Makefile.common
diff --git a/x11-plugins/asapm/files/asapm-3.1-include.patch b/x11-plugins/asapm/files/asapm-3.1-include.patch
new file mode 100644
index 000000000000..529d994ef122
--- /dev/null
+++ b/x11-plugins/asapm/files/asapm-3.1-include.patch
@@ -0,0 +1,10 @@
+--- a/apm_read.c
++++ b/apm_read.c
+@@ -13,6 +13,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h> /* exit(), free() */
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <unistd.h>
diff --git a/x11-plugins/asapm/files/asapm-3.1-ldflags.patch b/x11-plugins/asapm/files/asapm-3.1-ldflags.patch
new file mode 100644
index 000000000000..a90d7baf2e4e
--- /dev/null
+++ b/x11-plugins/asapm/files/asapm-3.1-ldflags.patch
@@ -0,0 +1,11 @@
+--- a/autoconf/Makefile.common.in
++++ b/autoconf/Makefile.common.in
+@@ -34,7 +34,7 @@
+ done
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
++ $(CC) $(LDFLAGS) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
+
+ .c.o:
+ $(CC) $(CCFLAGS) $(EXTRA_DEFINES) $(INCLUDES) $(EXTRA_INCLUDES) -c $*.c