summaryrefslogtreecommitdiff
path: root/x11-plugins/ascpu/ascpu-1.11-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/ascpu/ascpu-1.11-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/ascpu/ascpu-1.11-r1.ebuild')
-rw-r--r--x11-plugins/ascpu/ascpu-1.11-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-plugins/ascpu/ascpu-1.11-r1.ebuild b/x11-plugins/ascpu/ascpu-1.11-r1.ebuild
new file mode 100644
index 000000000000..ab325222b55d
--- /dev/null
+++ b/x11-plugins/ascpu/ascpu-1.11-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="CPU statistics monitor utility for X Windows"
+SRC_URI="http://www.tigr.net/afterstep/download/ascpu/${P}.tar.gz"
+HOMEPAGE="http://www.tigr.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
+IUSE="jpeg"
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libSM
+ jpeg? ( virtual/jpeg:0 )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+PATCHES=( "${FILESDIR}/${P}-gentoo-r1.patch" )
+
+src_configure() {
+ econf $(use_enable jpeg)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ dodoc README
+ default
+}