summaryrefslogtreecommitdiff
path: root/x11-plugins/e16-epplets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /x11-plugins/e16-epplets
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'x11-plugins/e16-epplets')
-rw-r--r--x11-plugins/e16-epplets/Manifest3
-rw-r--r--x11-plugins/e16-epplets/e16-epplets-0.16.ebuild49
-rw-r--r--x11-plugins/e16-epplets/metadata.xml22
3 files changed, 74 insertions, 0 deletions
diff --git a/x11-plugins/e16-epplets/Manifest b/x11-plugins/e16-epplets/Manifest
new file mode 100644
index 000000000000..9c1d464d30d5
--- /dev/null
+++ b/x11-plugins/e16-epplets/Manifest
@@ -0,0 +1,3 @@
+DIST e16-epplets-0.16.tar.xz 800796 BLAKE2B 70785fce2949bb5e3b0f950436e63246b576dc2dc13ac392e2d884f913e0f22e68b428b416e20807adfb47ca7a148bb3242efff6dbeac8c734ed645ff3f1c705 SHA512 2cc90dee741a50f54665078db6197d7736d5423419439e640d5170057b80111458dbf4b7c9a92898e96654b1af4a986e5cedb88a565616e70ed0fba6ec82cd9b
+EBUILD e16-epplets-0.16.ebuild 978 BLAKE2B 5bd2796dfccee27f17ed41d8a7cd18b17bcfcba3cb6cfe11276441881355de7af88ffc05b9f8359561f6abf8e79fda489e02b3d276dffd86ca494b23045a3fa1 SHA512 319df8d1e78a3c808d5edf6fd3bc47c64d6a0a9ad02f530d5fc4e1595242438fb581ffc5af1064e2eee505dfb1f72d4eb9a170b4b771acb051037e6320a9335c
+MISC metadata.xml 947 BLAKE2B e8ebeb56e1f7cfb9215352c5eabeb2fd75fd558f0ad0006ea7aea5ae7af8510a55727b9a0d31ac0b24d033f2b40091978c25ce931eac12eac944ef3cb7b1adb0 SHA512 64c6ffcab76449ec17c6d36994de2fb95468dfef6fb0d65811feb6a38cf1aa0d080353b782f57dffc6e3cb619d2bbbb847170a6c52578e7ad8e1d87e3f15a3d4
diff --git a/x11-plugins/e16-epplets/e16-epplets-0.16.ebuild b/x11-plugins/e16-epplets/e16-epplets-0.16.ebuild
new file mode 100644
index 000000000000..130edb033503
--- /dev/null
+++ b/x11-plugins/e16-epplets/e16-epplets-0.16.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Enlightenment DR16 epplets"
+HOMEPAGE="https://www.enlightenment.org https://sourceforge.net/projects/enlightenment/"
+SRC_URI="mirror://sourceforge/enlightenment/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2+ BSD public-domain"
+SLOT="0"
+IUSE="cdaudio libgtop opengl"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+CDEPEND="
+ cdaudio? ( media-libs/libcdaudio )
+ libgtop? ( gnome-base/libgtop )
+ opengl? ( media-libs/glu media-libs/mesa )
+ >=media-libs/imlib2-1.2.0
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-wm/e16
+"
+RDEPEND="${CDEPEND}
+ !x11-plugins/epplets
+"
+DEPEND="${CDEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable cdaudio)
+ $(use_enable opengl glx)
+ $(use_with libgtop)
+ --disable-esd
+ --disable-static
+ --disable-werror
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}"/usr -name '*.la' -delete || die
+}
diff --git a/x11-plugins/e16-epplets/metadata.xml b/x11-plugins/e16-epplets/metadata.xml
new file mode 100644
index 000000000000..8f913313833b
--- /dev/null
+++ b/x11-plugins/e16-epplets/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+ <use>
+ <flag name="cdaudio">Enable CD Audio support using <pkg>media-libs/libcdaudio</pkg></flag>
+ <flag name="libgtop">Use <pkg>gnome-base/libgtop</pkg> to obtain system load information</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">enlightenment</remote-id>
+ </upstream>
+ <longdescription>
+ Epplets are small, handy Enlightenment applets, similar to "dockapps"
+ or "applets" for other packages. The epplets package contains the
+ base epplet API library and header files, as well as the core set of
+ epplets, including CPU monitors, clocks, a mail checker, mixers, a
+ slideshow, a URL grabber, a panel-like toolbar, and more.
+ </longdescription>
+</pkgmetadata>