summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
commit423d21dcfee183cc4b04d29c1621615e8c30f834 (patch)
tree23bd6110b9a77b8d679b5ab60fb7663b8627f698 /x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2-r1.ebuild
parent81e4fbcb846ed1cabdad699c0029b166dd7273b7 (diff)
gentoo resync : 04.01.2018
Diffstat (limited to 'x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2-r1.ebuild')
-rw-r--r--x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2-r1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2-r1.ebuild b/x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2-r1.ebuild
index f8679d71309f..dcf420b95721 100644
--- a/x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2-r1.ebuild
+++ b/x11-plugins/gkrellm-cpupower/gkrellm-cpupower-0.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,25 +16,24 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-S="${WORKDIR}/${MY_P}"
-
+DEPEND="app-admin/gkrellm:2[X]"
RDEPEND="
- app-admin/gkrellm[X]
+ ${DEPEND}
app-admin/sudo
- sys-power/cpupower
-"
+ sys-power/cpupower"
-PLUGIN_SO="cpupower.so"
+S=${WORKDIR}/${MY_P}
src_install() {
+ local PLUGIN_SO=( cpupower$(get_modname) )
gkrellm-plugin_src_install
emake DESTDIR="${D}" install-sudo
}
pkg_postinst() {
- echo
+ einfo
einfo "For changing the governor and CPU frequencies as a user, create the \"trusted\""
einfo "group, and add those users to that group who should be allowed to perform"
einfo "these changes."
- echo
+ einfo
}