summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r2.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r2.ebuild')
-rw-r--r--x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r2.ebuild b/x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r2.ebuild
new file mode 100644
index 000000000000..fed6fcfc799b
--- /dev/null
+++ b/x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin autotools
+
+MY_P="${P/rellm-/}"
+
+DESCRIPTION="GKrellM2 plugin for monitoring keyboard LEDs"
+HOMEPAGE="http://heim.ifi.uio.no/~oyvinha/gkleds/"
+SRC_URI="http://heim.ifi.uio.no/~oyvinha/e107_files/downloads/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-r2-ldflags-typo.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ PLUGIN_SO=( src/.libs/gkleds$(get_modname) )
+ default
+}