summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5-r1.ebuild')
-rw-r--r--x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5-r1.ebuild b/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5-r1.ebuild
new file mode 100644
index 000000000000..a3f3ab6d277b
--- /dev/null
+++ b/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="A Program-Launcher Plugin for GKrellM2"
+SRC_URI="mirror://sourceforge/gkrellmlaunch/${P}.tar.gz"
+HOMEPAGE="http://gkrellmlaunch.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-r1-pkgconfig.patch
+)
+
+src_compile() {
+ tc-export PKG_CONFIG
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}