summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellsun/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/gkrellsun/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/gkrellsun/files')
-rw-r--r--x11-plugins/gkrellsun/files/gkrellsun-1.0.0-Respect-LDFLAGS.patch13
-rw-r--r--x11-plugins/gkrellsun/files/gkrellsun-1.0.0-reenable.patch16
2 files changed, 29 insertions, 0 deletions
diff --git a/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-Respect-LDFLAGS.patch b/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-Respect-LDFLAGS.patch
new file mode 100644
index 000000000000..548039dd0e0b
--- /dev/null
+++ b/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-Respect-LDFLAGS.patch
@@ -0,0 +1,13 @@
+diff --git a/src20/Makefile b/src20/Makefile
+index 3e8e62c..ef96fa2 100644
+--- a/src20/Makefile
++++ b/src20/Makefile
+@@ -16,6 +16,8 @@ FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE)
+ LIBS = $(GTK_LIB)
+ LFLAGS = -shared
+
++LFLAGS += $(LDFLAGS)
++
+ ifeq ($(enable_nls),1)
+ FLAGS += -DENABLE_NLS -DLOCALEDIR=\"$(LOCALEDIR)\"
+ export enable_nls
diff --git a/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-reenable.patch b/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-reenable.patch
new file mode 100644
index 000000000000..f47b96e88905
--- /dev/null
+++ b/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-reenable.patch
@@ -0,0 +1,16 @@
+diff --git a/src20/gkrellsun.c b/src20/gkrellsun.c
+index f3adff5..0738bfc 100644
+--- a/src20/gkrellsun.c
++++ b/src20/gkrellsun.c
+@@ -1140,7 +1140,10 @@ cb_plugin_disabled()
+
+ save_sun_data();
+
+- if (textOptions.fontDesc) pango_font_description_free (textOptions.fontDesc);
++ if (textOptions.fontDesc) {
++ pango_font_description_free (textOptions.fontDesc);
++ textOptions.fontDesc = NULL;
++ }
+
+ /* This happens when user quits X Windows and gkrellm2 is still running */
+ if (colormap == NULL)