summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-encryption
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /x11-plugins/pidgin-encryption
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'x11-plugins/pidgin-encryption')
-rw-r--r--x11-plugins/pidgin-encryption/Manifest2
-rw-r--r--x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild (renamed from x11-plugins/pidgin-encryption/pidgin-encryption-3.1.ebuild)25
2 files changed, 14 insertions, 13 deletions
diff --git a/x11-plugins/pidgin-encryption/Manifest b/x11-plugins/pidgin-encryption/Manifest
index 7fc45ad69def..d27eb7c1f4d5 100644
--- a/x11-plugins/pidgin-encryption/Manifest
+++ b/x11-plugins/pidgin-encryption/Manifest
@@ -1,4 +1,4 @@
AUX pidgin-encryption-3.1-glib2.32.patch 381 BLAKE2B 0f62640d14f2da191de008f7a5a984d2a1462400eccc9c83e890fbdb0e4be271cac9e692af2619307de95ddc198e2d0e19a36dde55d617ddcdd69d15f90455df SHA512 1c6b3c34d0e8acab7dd4465348d674b56d8939305e87dc9e59bd14e99e7123e865c4e6a91f641e3365c507b2d88e19541f05534b3255ab23754d95d49c997639
DIST pidgin-encryption-3.1.tar.gz 604129 BLAKE2B d42c6baf9e1b0adcb8e88a611279fa66f6c37ce3e89c742c6a8e2662662576cc9e08c8e3fa08c19e857b88165b840826f9118c5bcca0098b7eb02fac0a8ae159 SHA512 681e719dacc6812f6e965b5025631b02dc6abe4694c4dfc3034d5c07e97798707f28920c142b99f9d428470ef5c14bffe5d7c62d2d5fce01ad0e7567ab60b32d
-EBUILD pidgin-encryption-3.1.ebuild 727 BLAKE2B efcc7e2b3042ff5985d17abd8544222f3c8c0164e25ebd378d1a6db3ac068664757ef969416740e57ed4066324d3d62affdb985af55ea560764bedfecbea881b SHA512 b75cd4d2e112416c3c5220e2f878176ab7b00f593131004789f0459f96784eed7a8feb6aca9c0546e7341b715b211eae114527ba96ea1e287d2ea25a1a2ca76b
+EBUILD pidgin-encryption-3.1-r1.ebuild 736 BLAKE2B dbaf9a51fdd834c7d9535ecb420cb1fbaecc460519eec862796dea9147bd587b5e1a2cbee83f8622388007174f2d18d64dcaf694ac8c149d5be5b4cfaf575042 SHA512 52dab8918a7080257dd19d7bb18b89e0b6be277c218d7e0282b7e4a84183496f00643f99b341a7c9b91ef018620c4fa94018eb28788cf437c4b9be05c0c16cfe
MISC metadata.xml 251 BLAKE2B 5461a66aa7bd7a3a15d3683470b35e5599778fd3000f5087f77190ea0e75dfa69dc059757a326c4c323ce5f10518144ef30ecd61fcbc8a6abb1b3ae43dbb89c7 SHA512 a375797fe97db08ac4975c1fc0d8630f65597b2d764f93fc119eda3f7454c094968cb321497b45b63be43221517498b15862b20380600d058d4b9d1376380044
diff --git a/x11-plugins/pidgin-encryption/pidgin-encryption-3.1.ebuild b/x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild
index 561a3df71d68..28f7c2dbaecf 100644
--- a/x11-plugins/pidgin-encryption/pidgin-encryption-3.1.ebuild
+++ b/x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit flag-o-matic eutils
+inherit flag-o-matic
DESCRIPTION="Pidgin IM Encryption PlugIn"
HOMEPAGE="http://pidgin-encrypt.sourceforge.net/"
@@ -14,24 +14,25 @@ SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 sparc x86"
IUSE="nls"
-RDEPEND="net-im/pidgin[gtk]
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ >=dev-libs/nss-3.11
+ net-im/pidgin[gtk]
x11-libs/gtk+:2
- >=dev-libs/nss-3.11"
+"
+DEPEND="${RDEPEND}"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-glib2.32.patch"
-}
+PATCHES=(
+ "${FILESDIR}/${P}-glib2.32.patch"
+)
src_configure() {
strip-flags
replace-flags -O? -O2
- econf $(use_enable nls)
+ econf $(use_enable nls) --disable-static
}
src_install() {
- emake install DESTDIR="${D}"
+ emake install DESTDIR="${ED}"
dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
}