summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-04 23:52:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-04 23:52:39 +0100
commit1b2c0d19f75523db182b267901484f87abf732cf (patch)
tree3c4832e97c3846189d07c64c2eba333bf33b8ab2 /x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild
parentdd851ab76c56a249df7a0ec052acd90940bc014f (diff)
gentoo auto-resync : 04:10:2023 - 23:52:39
Diffstat (limited to 'x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild')
-rw-r--r--x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild b/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild
new file mode 100644
index 000000000000..f1d7ce738b0f
--- /dev/null
+++ b/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="(OTR) Messaging allows you to have private conversations over instant messaging"
+HOMEPAGE="http://www.cypherpunks.ca/otr/"
+SRC_URI="http://www.cypherpunks.ca/otr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/libgcrypt:0
+ net-im/pidgin[gtk]
+ >=net-libs/libotr-4.0.0
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}"
+# autoconf-archive for F_S patch
+BDEPEND="
+ dev-util/intltool
+ sys-devel/autoconf-archive
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.2-dont-clobber-fortify-source.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}