summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-25 17:40:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-25 17:40:36 +0000
commit85809279ceef66e68b25eac8c3918bee6762f6cc (patch)
tree9ecee133212467e7b1402b70a11c5d6fb3ea817d /x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild
parent4215622c05ed14d30fdad5a4d0feba6d94b0d046 (diff)
gentoo auto-resync : 25:02:2024 - 17:40:36
Diffstat (limited to 'x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild')
-rw-r--r--x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild b/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..8c2af2004dc2
--- /dev/null
+++ b/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Pidgin plugin to stop spammers from annoying you"
+HOMEPAGE="https://code.google.com/p/pidgin-privacy-please/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="<net-im/pidgin-3[gtk]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ default
+ sed -e 's: -Wall -g3::' -i configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${D}" -type f -name '*.la' -delete || die "la removal failed"
+}