summaryrefslogtreecommitdiff
path: root/x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild')
-rw-r--r--x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild b/x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild
new file mode 100644
index 000000000000..7599c92c13b9
--- /dev/null
+++ b/x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="WMaker DockApp: Slightly modified version of Jamie Zawinski's xmatrix screenhack"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/17/${P}.tar.gz"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/10"
+
+CDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${CDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+RDEPEND="${CDEPEND}
+ x11-misc/xscreensaver"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ # this version is distributed with compiled binaries!
+ make clean
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)" || die "compile failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+}