summaryrefslogtreecommitdiff
path: root/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild')
-rw-r--r--x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild b/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild
index 9bd5996db7f1..7fdcae9bcf96 100644
--- a/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild
+++ b/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_PN="wmspaceweather"
MY_PV_ORIG="${PV/_p*}"
@@ -33,16 +33,17 @@ RDEPEND="${CDEPEND}
S="${WORKDIR}/${MY_P_ORIG/_/-}/${PN}"
-src_unpack() {
- unpack ${MY_P_ORIG}.tar.gz
- epatch "${DISTDIR}"/${MY_P_PATCH}.gz
- epatch "${FILESDIR}"/${P}-gcc-10.patch
+src_prepare() {
+ default
+
+ cd .. || die
+
+ eapply "${WORKDIR}"/${MY_P_PATCH}
+ eapply "${FILESDIR}"/${P}-gcc-10.patch
# need to apply patches from Debian first, do NOT change the order
cd "${S}" || die
- mv ../debian/patches "${WORKDIR}"/patch || die
- EPATCH_SUFFIX="dpatch" EPATCH_FORCE="yes" \
- EPATCH_MULTI_MSG="Applying Debian patches ..." epatch
+ eapply -p2 ../debian/patches/*.dpatch
eapply "${FILESDIR}"/${P}-gentoo.patch
eapply "${FILESDIR}"/${P}-getkp.patch
}