summaryrefslogtreecommitdiff
path: root/x11-plugins/wmail/wmail-2.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmail/wmail-2.0-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmail/wmail-2.0-r3.ebuild')
-rw-r--r--x11-plugins/wmail/wmail-2.0-r3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-plugins/wmail/wmail-2.0-r3.ebuild b/x11-plugins/wmail/wmail-2.0-r3.ebuild
new file mode 100644
index 000000000000..26ce557e8372
--- /dev/null
+++ b/x11-plugins/wmail/wmail-2.0-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+DESCRIPTION="Window Maker dock application showing incoming mail"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/70"
+SRC_URI="http://www.minet.uni-jena.de/~topical/sveng/wmail/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="<x11-libs/libdockapp-0.7"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.1.4-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}.support-libdockapp-0.5.0.patch
+
+ # make from parsing in maildir format faster, thanks
+ # to Stanislav Kuchar
+ epatch "${FILESDIR}"/${P}.maildir-parse-from.patch
+
+ # fix LDFLAGS ordering, see bug #248620
+ sed -i 's/$(LIBS) -o $@ $^/-o $@ $^ $(LIBS)/' "${S}/src/Makefile.in"
+
+ # Honour Gentoo LDFLAGS, see bug #337407
+ sed -i 's/-o $@ $^ $(LIBS)/$(LDFLAGS) -o $@ $^ $(LIBS)/' "${S}/src/Makefile.in"
+}
+
+src_compile() {
+ econf --enable-delt-xpms || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ dobin src/wmail
+ dodoc README wmailrc-sample
+}